Abilitazione di connessioni sicure al negozio Shopify

L'abilitazione di connessioni sicure al tuo negozio Shopify garantisce che i dati inseriti dai clienti rimangano privati e sicuri. Questo risultato viene ottenuto utilizzando un certificato TLS (Transport Layer Security), talvolta indicato come certificato SSL (Secure Sockets Layer), che crittografa la comunicazione tra il negozio e il contenuto esterno e pubblica il contenuto in modo sicuro utilizzando il protocollo HTTPS invece di quello HTTP.

Ad esempio, se l'URL del tuo negozio è http://www.example.com, quando verrà emesso il certificato TLS, l'URL verrà modificato in https://www.example.com. Se i clienti utilizzano l'URL originale, vengono automaticamente reindirizzati al negozio online crittografato.

I certificati TLS presentano i vantaggi seguenti per il tuo negozio online:

  • Aggiungono un livello di sicurezza crittografando i dati dei clienti.
  • Aiutano a infondere fiducia nei clienti mostrando l'icona del lucchetto accanto all'URL del negozio online.
    Connection is secure padlock icon

Acquisizione di un certificato TLS

I certificati TLS vengono forniti gratuitamente per tutti i domini aggiunti a Shopify. Il certificato TLS viene emesso automaticamente nelle circostanze seguenti:

  • per tutte le risorse ospitate sul dominio .myshopify.com;
  • quando acquisti un dominio personalizzato tramite Shopify o ne trasferisci uno a Shopify;
  • quando colleghi il dominio di terze parti a Shopify modificando il record A e il record CNAME in modo che puntino a Shopify; in questo caso, l'emissione del certificato TLS potrebbe richiedere fino a 48 ore. Durante questo periodo potrebbe essere visualizzato un errore SSL non disponibile nel pannello di controllo Shopify. Potrebbe anche essere visualizzato un errore di sicurezza nel browser quando i clienti visitano il negozio online. Se dopo oltre 48 ore nel negozio viene ancora visualizzato un errore di sicurezza, contatta l'Assistenza Shopify.

Puoi assicurarti che l'emissione del certificato TLS sia avvenuta verificando sulla pagina Domini che lo stato del dominio sia Connected. Inoltre, quando visiti la tua vetrina virtuale, l'icona del lucchetto viene visualizzata accanto all'URL del negozio online, nella barra degli indirizzi.

Verifica della sicurezza delle risorse

Se il tuo negozio online include immagini, video, web font o altre risorse non ospitate da Shopify, queste dovrebbero essere trasferite tramite il protocollo HTTPS. Tutte le pagine del negozio online Shopify che includono una risorsa non trasferita tramite il protocollo HTTPS non sono considerate sicure.

L'opzione migliore per garantire che le risorse siano sicure consiste nell'ospitare tutte le risorse del negozio online su Shopify.

Se hai bisogno di ospitare le tue risorse al di fuori di Shopify, assicurati di eseguire le operazioni seguenti:

Record CAA (Certification Authority Authorization)

Il record CAA (Certification Authority Authorization) viene utilizzato per specificare le autorità di certificazione autorizzate a emettere certificati per un dominio. Un'autorità di certificazione (CA) è un'entità affidabile che emette documenti elettronici per verificare l'identità di un'entità digitale presente su Internet.

Per il negozio non sono necessari record CAA. Tuttavia, se devi utilizzarli, nel momento in cui colleghi il tuo dominio a Shopify devi aggiungere a ogni record CAA le autorità di certificazione (CA) seguenti:

Risoluzione dei problemi relativi agli errori di sicurezza per un dominio di terze parti

Dopo che hai collegato il tuo dominio di terze parti a Shopify i clienti non riescono ad accedere al tuo negozio online.

Sintomo

Si verificano i seguenti errori:

  • Nel pannello di controllo Shopify viene visualizzato un errore TLS o SSL non disponibile.
  • Nella vetrina virtuale viene visualizzato un messaggio simile a Your connection is unsecure.

Causa

Una volta collegato il tuo dominio di terze parti a Shopify, l'emissione del certificato TLS può richiedere fino a 48 ore. Durante questo periodo nel pannello di controllo Shopify potrebbe essere visualizzato un errore TLS o SSL non disponibile. Se dopo 48 ore l'errore persiste, le impostazioni sul sito del provider di dominio potrebbero non essere state configurate correttamente.

Risoluzione

Se l'errore TLS o SSL non disponibile viene ancora visualizzato dopo 48 ore, procedi come segue:

  • Verifica che il tuo record A sia 23.227.38.65, che il record AAAA sia 2620:0127:f00f:5:: e che il record CNAME sia shops.myshopify.com.
  • Se utilizzi record CAA, verifica di aver aggiunto tutte le autorità di certificazione necessarie.
  • Se hai abilitato DNSSEC per il tuo dominio, disattivalo.

Se hai bisogno di altro aiuto, contatta l'Assistenza Shopify.

Sei pronto per iniziare a vendere con Shopify?

Provalo, è gratis