App compatibility

Not every app is built to work on every store. Some apps are designed to work with specific store settings. To prevent you from installing apps that don't work on your store, app developers can set installation requirements for their apps.

If your store’s settings don’t meet an app’s installation requirements, then the app is marked as Not compatible in the Shopify App Store. On the app listing page for an incompatible app, you can see which installation requirements don't meet your store's settings. You can't install the app unless those settings change. On the search and category pages, you can hide incompatible apps by selecting See only compatible apps.

If an app that you've already installed becomes incompatible with your store, then you'll get an app notification in the Shopify admin that explains what store settings are incompatible with the app.

Installation requirements are associated with store settings that are difficult to change, like your business location or the countries you ship to. In most cases, we recommend you find alternative apps that work for your store, unless you're planning to change your business setup.

There are 5 types of installation requirements that an app can have:

Online Store: The app works with stores that have the Online Store channel.

Point of sale: The app works with stores that have the Shopify Point of Sale channel.

Shipping countries: The app works with stores that ship to at least one of the specified countries. The countries you ship to are set by your shipping zones.

Currency: The app works with stores that sell in at least one of the currencies that the app supports.

Business address: The app works with stores with a primary business address in a country that the app supports.

Ready to start selling with Shopify?

Try it free