Resolving return errors for Shopify Fulfillment Network
When Shopify Fulfillment Network (SFN) can't process your return, a return label isn't generated. In this case, an error message is displayed in your Shopify admin and SFN app. You might need to update your customer's shipping details or contact SFN to find a solution for the error.
When there's an error with your return, the order for that return displays a Return failed status in your Shopify admin and a Rejected status in your SFN app. The Return failed section of your order details page displays the error and the action you can take to resolve the return issue.
Refer to the following sections to find the reason for the return error and the steps to resolve it.
Error: Your return failed because at least 1 item wasn't accepted
After you create a return, a return label to SFN isn't generated.
Symptom
The following errors occur:
- The order details page in your Shopify admin displays the following error:
Your return failed because at least 1 item wasn't accepted. Update the return with a new return shipping method or contact Shopify Fulfillment Network for details.
- The order displays a Rejected status in your SFN app.
Cause
The return contains an item that SFN doesn’t stock and can't accept.
Resolution
To resolve this error, you need to perform the following tasks:
- Cancel the return that has the error.
- Create a new return for the order, and then select a different shipping method.
Error: Couldn’t generate shipping label
After you create a return, a return label to SFN isn't generated.
Symptom
The following errors occur:
- The order details page in your Shopify admin displays the following error:
Couldn’t generate shipping label. Contact Shopify Fulfillment Network for details.
- The order displays a Rejected status in your SFN app.
Cause
SFN encountered an error when trying to create a return label.
Resolution
To resolve this error, you need to perform the following tasks:
- Confirm that the order wasn't already sent out using a pre-authorized return label.
- Cancel the return that has the error.
- Contact Shopify Fulfillment Network to determine the next steps.
Error: Return to Shopify Fulfillment Network is only available for US addresses
After you create a return, a return label to SFN isn't generated.
Symptom
The following errors occur:
- The order details page in your Shopify admin displays the following error:
Return to Shopify Fulfillment Network is only available if your customer shipping address is set in the US.
- The order displays a Rejected status in your SFN app.
Cause
This error can occur for the following reasons:
- The customer shipping address isn’t located in the US.
- Customer shipping information is missing.
Resolution
To resolve this error, you need to perform the following tasks:
- Cancel the return that has the error.
- Depending on the reason for the error, do one of the following:
- To add missing customer shipping information, edit the customer's profile, and then create a new return for the order.
- To create a return for a customer located outside of the US, create a new return for the order, and then select a different shipping method.