アプリの互換性

すべてのアプリがどのようなストアでも動作するように構築されているわけではありません。一部のアプリは特定のストア設定の下で動作するように設計されています。ストアで動作しないアプリをインストールしてしまうことを防ぐために、アプリ開発者はアプリにインストール要件を設定できます。

ストアの設定がアプリのインストール要件を満たしていない場合、アプリはShopify アプリストアで互換性がありませんとしてマークされます。互換性のないアプリのアプリのリストページで、ストアの設定に合わないインストール要件を確認することができます。これらの設定が変更されない限り、アプリをインストールすることはできません。検索とカテゴリーページでは、互換性のあるアプリのみを見るを選択することにより、互換性のないアプリを非表示にすることができます。

すでにインストールしたアプリがストアと互換性がない場合、管理画面には、アプリと互換性がないストアの設定について説明するアプリの通知が表示されます。

インストール要件は、ビジネスのロケーションや配送先の国など、変更が難しいストア設定と関連があります。ビジネスの設定を変更する予定がない限り、ほとんどの場合、ストアに適した代替アプリを探すことをおすすめします。

アプリのインストール要件には、5種類のタイプがあります。

  • POS: アプリはShopify POSチャネルを使用するストアで動作します。

  • 配送先の国: アプリは、指定された国の少なくとも1つに配送するストアで動作します。配送先の国は配送エリアで設定されます。

  • 通貨: アプリは、アプリがサポートする通貨の少なくとも1つを使用して販売するストアで動作します。

  • ビジネスの住所: アプリは、アプリがサポートする国に主なビジネスの住所を持つストアで動作します。

  • オンラインストア: アプリは、ストアにオンラインストアのチャネルがある場合に動作します。

    オンラインストアチャネルと連動する一部のアプリは、以前のテーマでしか利用できない場合があります。Online Store 2.0テーマを使用している場合、アプリのリストとドキュメントを読んで、アプリと利用しているテーマに互換性があるかどうかを確かめる必要があります。オンラインストアチャネルでアプリを使用する方法について詳しくはこちらをご覧ください。

Shopifyで販売を開始する準備はできていますか?

無料体験を試す