使用 Maya 和 Substance Painter 建立 GLB 檔案

使用 Maya 和 Substance Painter 匯出可上傳至 3D Warehouse 的 GLB 檔案。

在 Maya 為模型準備匯出工作

若要準備進行模型匯出,您需要確認該模型屬於單一 mesh,且僅套用單一材質。

步驟:

  1. 前往 File (檔案) > Import... (匯入...),選取您的 3D 檔案,然後按一下 Import (匯入),將您的模型匯入 Maya。
  2. 按一下 Mesh > Combine (組合),將您的 mesh 組合成單一物件。
  3. 將模型展拆至 0-1 UV 空間。確認 UV 皆未重疊:
    使用 UV 編輯器,在 X 和 Y 軸的 0 和 1 之間展開 UV。
  4. 將 Phong 材質套用至模型:
    1. 將滑鼠游標移至模型上,按一下右鍵不放,然後選取 Assign New Material... (指派新材質)
    2. 從對話方塊中選取 Phong

從 Maya 匯出 mesh

  1. 選取整個 mesh,然後按一下 File (檔案) > Export Selection... (匯出選取項目)
  2. 請輸入檔案名稱和檔案儲存位置。
  3. Files of type (檔案類型) 下拉式選單中選取 OBJexport
  4. 按一下 Export Selection (匯出選取項目)

在 Substance Painter 中匯入和準備 OBJ 檔案

  1. 按一下「檔案 > 新增」,建立新的 Substance Painter 專案。
  2. 按一下「新專案」對話方塊中的「選擇」並選擇 mesh。
  3. 選擇您由 Maya 匯出的 OBJ 檔案,然後按一下「開啟」。
  4. 按一下「新專案」視窗中的「確定」。
  5. 檢查「紋理集列表」面板中是否只有一個紋理集,以便驗證 mesh 有沒有正確匯出。

    如果您看到多個紋理集,請參閱「多重紋理集」

  6. 「紋理集設定」面板中,按一下 + 按鈕來新增管道:

    + 按鈕位於「管道」標頭旁。這個按鈕會開啟下拉式選單,選單內會顯示其他可用的管道。

- 必要項目:環境光遮蔽。 - 選用項目:放射光。如果您的模型具有會發光的元件,請新增此管道。 - 選用項目:透明度。如果您的模型具有透明的元件,請新增此管道。

  1. 按一下「紋理集設定」面板上的「烘焙紋理貼圖」。

  2. 在模型上印上紋理。

多重紋理集

您將 OBJ 檔案匯入 Substance Painter 後,應該只會看到一個紋理集:

「紋理集列表」面板會列出紋理集。

如果您看到的紋理集超過一個,那就表示從 Maya 匯出 mesh 時以下其中一個項目有誤:

  • mesh 未合併為單一物件。
  • mesh 上指派了一個以上的紋理。

如果情況如此,請再度從 Maya 匯出模型,然後確認 mesh 是單一物件,並只有指派一個紋理。

從 Substance Painter 匯出 glTF 檔案

  1. 按一下「檔案」>「匯出紋理」。
  2. 「設定」下拉式選單中選擇「glTF PBR 金屬粗糙度」
  3. 選擇您想儲存紋理的位置。
  4. 選擇文件大小,以便決定紋理檔案大小。
  1. 按一下「匯出」。

壓縮紋理檔案

匯出模型後,您應該會有下列檔案:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Substance Painter 使用「glTF PBR 金屬粗糙度」設定時只會以 PNG 格式輸出紋理檔案。請考慮壓縮紋理檔案,並將不需要 alpha 管道的紋理轉換為 JPG。這樣做可以降低檔案的整體大小,而較小的檔案就能達到更快的下載速度,並有更順暢的互動體驗。

檔案大小最好保持在 3MB 或以下。

建立 GLB 檔案

  1. 請至 https://glb-packer.glitch.me/
  2. 將您從 Substance Painter 匯出的檔案拖曳到 GLB Packer 網頁上。

您的電腦會開始下載名為「out.glb」的檔案,下載完畢後,您可以重新命名檔案,然後再上傳到 3D Warehouse。

準備好開始透過 Shopify 銷售商品了嗎?

免費試用