Creare file GLB usando Maya e Substance Painter

Utilizza Maya e Substance Painter per esportare un file GLB che può essere aggiunto a un prodotto nel pannello di controllo Shopify.

Prepara il tuo modello per l'esportazione in Maya

Per preparare il tuo modello per l'esportazione, devi assicurarti che si tratti di una singola mesh e che ad essa sia applicato un solo materiale.

Procedura:

  1. Importa il tuo modello in Maya andando su File > Import..., scegliendo il tuo file 3D, quindi cliccando su Import.
  2. Clicca su Mesh > Combine per unificare la tua mesh in un singolo oggetto.
  3. Apri il modello nello spazio UV 0-1. Assicurati che nessun UV si sovrapponga:
    Usa l'Editor UV per disporre gli UV tra 0 e 1 sugli assi X e Y.
  4. Applica un materiale Phong al modello:
    1. Con il cursore del mouse sul modello, clicca con il pulsante destro e tieni premuto, quindi seleziona Assign New Material...
    2. Dalla finestra di dialogo, seleziona Phong.

Esporta la mesh da Maya

  1. Seleziona l'intera mesh, quindi clicca su File > Export Selection...
  2. Inserisci un nome per il file e la destinazione dove va salvato il file.
  3. Dal menu a tendina Files of type, seleziona OBJexport.
  4. Clicca su Export Selection.

Importa e prepara il file OBJ con Substance Painter

  1. Crea un nuovo progetto Substance Painter cliccando su File > Nuovo.
  2. Nella finestra di dialogo Nuovo progetto, clicca su Seleziona per scegliere una mesh.
  3. Seleziona il file OBJ che hai esportato da Maya e clicca su Apri.
  4. Nella finestra Nuovo progetto, clicca su OK.
  5. Verifica di aver esportato correttamente la mesh controllando che sia presente un solo set di texture nel pannello Elenco set texture.

    Se vedi più di un set di texture, controlla Set di texture multiple.

  6. Nel pannello Impostazioni set di texture, clicca sul pulsante + per aggiungere dei canali:

    Il pulsante + si trova accanto all'intestazione Canali. Il pulsante apre un menu a tendina che mostra gli altri canali disponibili.

- Obbligatoria: ambient occlusion. - Facoltativo: emissivo. Aggiungi questo canale se il tuo modello ha componenti che emetteranno luce. - Facoltativo: opacità. Aggiungi questo canale se il tuo modello ha componenti che saranno trasparenti.

  1. Nel pannello Impostazioni set di texture, clicca su Mappe Bake Mesh.

  2. Dipingi le texture sul modello.

Set di texture multipli

Quando importi il file OBJ su Substance Painter, devi visualizzare solo un set di texture:

I set di texture sono elencati nel pannello Elenco set di texture.

Se visualizzi più di un set di texture, si è verificato uno dei seguenti errori durante l'esportazione della mesh da Maya:

  • La mesh non è stata assemblata in un unico oggetto.
  • La mesh aveva più di una texture assegnata.

In questo caso, esporta nuovamente il tuo modello da Maya e assicurati che la mesh sia un singolo oggetto e abbia una sola texture assegnata.

Esporta il file glTF da Substance Painter

  1. Clicca su File > Esporta texture.
  2. Dal menu a tendina Config, seleziona Ruvidità metallo glTF PBR.
  3. Scegli dove salvare le tue texture.
  4. Scegli la dimensione del documento per determinare quanto saranno grandi i file delle texture.
  1. Fai clic su Esporta.

Compressione file texture

Una volta esportato il modello, dovresti avere i seguenti file:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Quando utilizzi la configurazione Ruvidità metallo glTF PBR, Substance Painter esporta i file di texture solo in formato PNG. Prendi in considerazione la possibilità di comprimere i file di texture e convertire nel formato JPG qualsiasi texture che non necessita di un canale alfa. Così ridurrai la dimensione totale dei file. Dimensioni di file più piccole consentono una maggiore velocità di download e interazioni più fluide.

Consigliamo di mantenere le dimensioni dei file entro i 4 MB o inferiori.

Crea un file GLB

  1. Visita https://glb-packer.glitch.me/.
  2. Trascina e rilascia i file che hai esportato da Substance Painter sulla pagina web di GLB Packer.

Un file chiamato out.glb sarà scaricato sul tuo computer. Al termine del download, puoi rinominare il file e quindi caricarlo su Shopify.

Sei pronto per iniziare a vendere con Shopify?

Provalo, è gratis