Erstellung von GLB-Dateien mit Maya und Substance Painter

Verwende Maya und Substance Painter, um eine GLB-Datei zu exportieren, die einem Produkt im Shopify-Adminbereich hinzugefügt werden kann.

Dein Modell für den Export in Maya vorbereiten

Um dein Modell für den Export vorzubereiten, musst du sicherstellen, dass es sich um ein einzelnes Mesh handelt und dass nur ein einziges Material verwendet wurde.

Schritte:

  1. Importieren Sie Ihr Modell in Maya, indem Sie File (Datei) > Import... wählen, Ihre 3D-Datei auswählen und dann auf Import klicken.
  2. Klicke auf Mesh > Combine (Kombinieren), um dein Mesh zu einem einzelnen Objekt zu kombinieren.
  3. Entpacke das Modell im 0-1-UV-Bereich. Stelle sicher, dass sich keine UVs überlappen:
    Verwenden Sie den UV-Editor, um die UVs zwischen 0 und 1 auf der X- und Y-Achse anzuordnen.
  4. Wende ein Phong-Material auf das Modell an:
    1. Fahre mit dem Mauszeiger über das Modell, klicke mit der rechten Maustaste und halte sie gedrückt, um dann Assign New Material... (Neues Material zuweisen) auszuwählen.
    2. Wähle im Dialogfeld Phong aus.

Exportieren Sie das Mesh aus Maya

  1. Wähle das gesamte Mesh aus und klicke auf File (Datei) > Export Selection... (Auswahl exportieren)
  2. Geben Sie einen Dateinamen und den Speicherort ein, an dem die Datei gespeichert werden soll.
  3. Wählen Sie im Dropdown-Menü Files of type (Dateien vom Typ) die Option OBJexport aus.
  4. Klicken Sie auf Export Selection (Auswahl exportieren).

Importieren Sie die OBJ-Datei in Substance Painter und bereiten Sie sie vor.

  1. Erstellen Sie ein neues Substance Painter-Projekt, indem Sie auf Datei > Neu klicken.
  2. Klicke im Dialogfeld Neues Projekt auf Auswählen, um ein Mesh auszuwählen.
  3. Wählen Sie die OBJ-Datei aus, die Sie aus Maya exportiert haben, und klicken Sie dann auf Öffnen.
  4. Klicken Sie im Fenster Neues Projekt auf OK.
  5. Überprüfen Sie, ob Sie Ihr Mesh richtig exportiert haben, indem Sie prüfen, dass in der Textur-Set-Liste nur ein Textur-Set vorhanden ist.

    Wenn mehrere Textur-Sets angezeigt werden, wird Mehrere Textur-Sets angezeigt.

  6. Klicken Sie im Fenster Textur-Set-Einstellungen auf die +-Schaltfläche, um Kanäle hinzuzufügen:

    Die +-Schaltfläche befindet sich neben der Überschrift

- Erforderlich: Umgebungsokklusion. - Optional: Emissiv. Füge diesen Kanal hinzu, wenn dein Modell über Komponenten verfügt, die Licht abgeben. - Optional: Opazität. Fügen Sie diesen Kanal hinzu, wenn Ihr Modell über transparente Komponenten verfügt.

  1. Klicke im Fenster Textur-Set-Einstellungen auf die Option für Mesh-Maps-Baking.

  2. Dem Modell Texturen zuweisen.

Mehrere Textur-Sets

Wenn Sie die OBJ-Datei in Substance Painter importieren, sollten Sie nur ein Textur-Set sehen:

Textur-Sets werden im Fenster mit der Textur-Set-Liste aufgeführt.

Wenn mehrere Textur-Sets angezeigt werden, lag eines der folgenden Probleme beim Export des Mesh aus Maya vor:

  • Das Mesh war nicht zu einem Objekt zusammengefasst.
  • Dem Mesh waren mehrere Texturen zugewiesen.

Falls dies der Fall ist, exportiere dein Modell erneut aus Maya und stelle sicher, dass es sich bei dem Mesh um ein einzelnes Objekt handelt und ihm nur eine Textur zugewiesen ist.

Exportiere die GlTIF-Datei aus Substance Painter

  1. Klicken Sie auf Datei > Texturen eportieren.
  2. Wählen Sie im Dropdown-Menü Konfig die Option glTF PBR Metal Roughness aus.
  3. Wählen Sie den Standort aus, an dem Sie Ihre Texturen speichern möchten.
  4. Wähle eine Dokumentgröße, um die Größe der Texturdateien anzugeben.
  1. Klicken Sie auf Exportieren.

Komprimieren von Texturdateien

Wenn Sie das Modell exportiert haben, müssen die folgenden Dateien vorhanden sein:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Bei Verwendung der glTF PBR Metal Roughness-Konfiguration exportiert Substance Painter Texturdateien nur im PNG-Format. Komprimieren Sie gegebenenfalls die Texturdateien und konvertieren Sie alle Texturen, die keinen Alphakanal benötigen, in das JPG-Format. Damit reduzieren Sie die Gesamtdateigröße, und geringere Dateigrößen ermöglichen kürzere Downloadzeiten und reibungslosere Interaktionen.

Wir empfehlen Dateigrößen bis maximal 4 MB.

Erstellen Sie eine GLB-Datei

Hinweis: Wenn Sie Ihre PNG-Bilder in JPG ändern möchten, dann müssen Sie die lesbare glTF-Datei bearbeiten und die notwendigen PNG-Referenzen in JPG ändern, bevor Sie die glTF in eine GLB packen. Öffnen Sie die glTF-Datei in einem Texteditor, aktualisieren Sie alle Dateinamen von PNG in JPG und speichern Sie die Datei.

  1. Besuchen Sie https://glb-packer.glitch.me/.
  2. Ziehen Sie die aus Substance Painter exportierten Dateien auf die GLB Packer-Webseite und legen Sie sie dort ab.

Eine Datei mit dem Namen out.glb wird auf Ihren Computer heruntergeladen. Nach Abschluss des Downloads können Sie die Datei umbenennen und anschließend in Shopify hochladen.