Crear archivos GLB utilizando Maya y Substance Painter

Utiliza Maya y Substance Painter para exportar un archivo GLB que pueda ser subido en 3D Warehouse.

Preparar tu modelo para exportalo en Maya

Para preparar tu modelo para exportarlo, debes asegurarte de que se trata de una malla única y de que tiene un solo material aplicado.

Pasos

  1. Importa tu modelo en Maya. Dirígete a Archivo > Importar..., selecciona tu archivo 3D y haz clic en Importar.
  2. Haz clic en Malla > Combinar para combinar tu malla con un solo objeto.
  3. Despliega el modelo en el espacio UV 0-1. Asegúrate de que los rayos UV no se solapen:
    Utiliza el editor UV para diseñar los UV entre 0 y 1 en los ejes X e Y.
  4. Aplica un material Phong al modelo:
    1. Con el cursor de tu mouse sobre el modelo, haz un clic con el botón derecho y luego selecciona Asignar nuevo material...
    2. Desde el cuadro de diálogo, selecciona Phong.

Exportar la malla de Maya

  1. Seleccionar toda la malla y luego haz clic en Archivo > Exportar selección...
  2. Introduce el nombre de un archivo y la ubicación donde debería estar guardado.
  3. En el menú desplegable Archivos de tipo, selecciona OBJexport.
  4. Haz clic en Exportar selección.

Importar y preparar el archivo OBJ en Substance Painter

  1. Crea un nuevo proyecto en Substance Painter haciendo clic en File > New.
  2. En el cuadro de diálogo New project, haz clic en Select para elegir una malla (mesh).
  3. Selecciona el archivo OBJ que exportaste de Maya y haz clic en Open.
  4. En la ventana New project, haz clic en OK.
  5. Verifica que exportaste correctamente tu malla verificando que solo haya un conjunto de textura en el panel de Texture set list.

    Si ves más de un conjunto de texturas, consulta Multiple texture sets.

  6. En el panel de Texture set settings, haz clic en el botón + para agregar canales:

    El botón + se encuentra al lado del título Channels. El botón abre un menú desplegable que muestra los canales adiciones disponibles.

- Obligatorio: Ambient occlusion. - Opcional: Emissive Agregar este canal si tu modelo tiene componentes que emiten luz. - Opcional: Opacity Agrega este canal si tu modelo tiene componentes transparentes.

  1. En el panel Texture set settings, haz clic en Bake Mesh Maps.

  2. Pintar texturas en el modelo.

Conjuntos de texturas múltiples

Cuando importas el archivo OBJ en Substance Painter, solo deberías ver un conjunto de texturas:

Los conjuntos de texturas están listados en el panel Listado de conjunto de texturas.

Si ves más de un conjunto significa que uno de los conjuntos tenía un error cuando se exportó la malla desde Maya

  • La malla no se combinó en un solo objeto.
  • La malla tenía más de una textura asignada.

De ser así, exporta tu modelo de Maya de nuevo y asegúrate de que la malla sea un objecto único y que solo tenga una textura asignada.

Exportar el archivo glTF a partir de Substance Painter

  1. Haz clic en File > Export Textures.
  2. A partir del menú desplegable Config, selecciona glTF PBR Metal Roughness.
  3. Selecciona el lugar donde deseas guardar tus texturas.
  4. Selecciona un tamaño de documento para determinar la dimensión de los archivos de textura.
  1. Haz clic en Exportar.

Comprimir archivos de textura

Una vez que hayas exportado el modelo deberías tener los siguientes archivos:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Cuando usas la configuración glTF PBR Metal Roughness, Substance Painter exporta solo los archivos de textura en formato PNG. Considera comprimir los archivos de textura y convertir cualquier textura que no necesite un canal alfa para un JPG. Esto reduce el tamaño total del archivo, y mientras más pequeño sea el archivo, mayor será la velocidad de descarga y mejor serán las interacciones.

Es mejor mantener un tamaño de archivo de 3MB o inferior.

Crear un archivo GLB

  1. Visita https://glb-packer.glitch.me/
  2. Arrastra y suelta los archivos que exportaste de Substance Painter en la página web de GLB Packer.

Se descargará un archivo llamado out.glb en tu computador. Una vez completada la descarga, cambia el nombre del archivo y súbelo a 3D Warehouse.

¿Estas listo(a) para comenzar a vender con Shopify?

Pruébala gratis