Crear archivos GLB utilizando Blender y Substance Painter

A partir de la versión 2.8, Blender puede exportar archivos de GLB que pueden agregarse a un producto en el panel de control de Shopify. Para obtener más información, consulta el manual de Blender.

Puedes combinar Blender y Substance Painter para exportar un archivo GLB en las versiones anteriores de Blender.

Preparar tu modelo para exportalo en Blender

Para preparar tu modelo para exportarlo, debes asegurarte de que se trata de una malla única y de que tiene una sola textura aplicada.

Pasos

  1. Haz clic en Archivo > Importar y selecciona el formato de archivo pertinente para tu modelo.
  2. Selecciona tu archivo de modelo y luego haz clic en Importar.
  3. Con la tecla SHIFT apoyada, haz un clic con el botón derecho en cada objeto de tu escenario y presiona Ctrl + J para unirlos a la malla.
  4. Despliega el modelo en el espacio UV 0-1. Asegúrate de que los rayos UV no se solapen:
    En el editor de UV/Imagen, asegúrate de que todos los UV estén colocados en la cuadrícula.
  5. En el editor Propiedades, haz clic en el ícono de materiales.
  6. Haz clic en el botón + para agregar una nueva ranura de material:
    El botón 'Agregar una ranura de material' está cerca de la parte superior del panel 'Material'.
  7. Haz clic en Nuevo.

Exportar la malla de Blender

  1. Haz clic en Archivo > Exportar > FBX (.fbx)
  2. Introduce la ruta a donde quieres exportar el archivo.
  3. Asegúrate de usar la siguiente configuración de exportación:
    Versión: FBX 7.4 binario. Escala: 1.0. Aplicar escalas: todas ubicaciones. Avanzar: -Z avanzar. Arriba: Y arriba. Modo de ruta: auto. Modo de lote: off.
  4. Haz clic en Exportar FBX.

Importar y preparar el archivo FBX en Substance Painter

  1. Crea un nuevo proyecto en Substance Painter haciendo clic en File > New.
  2. En el cuadro de diálogo New project, haz clic en Select para elegir una malla (mesh).
  3. Selecciona el archivo FBX que exportaste de Blender y haz clic en Open.
  4. En la ventana New project, haz clic en OK.
  5. Verifica que exportaste correctamente tu malla verificando que solo haya un conjunto de textura en el panel de Texture set list.

    Si ves más de un conjunto de texturas, consulta Multiple texture sets.

  6. En el panel de Texture set settings, haz clic en el botón + para agregar canales:

    El botón + se encuentra al lado del título Channels. El botón abre un menú desplegable que muestra los canales adiciones disponibles.

- Obligatorio: Ambient occlusion. - Opcional: Emissive Agregar este canal si tu modelo tiene componentes que emiten luz. - Opcional: Opacity Agrega este canal si tu modelo tiene componentes transparentes.

  1. En el panel Texture set settings, haz clic en Bake Mesh Maps.

  2. Pintar texturas en el modelo.

Conjuntos de texturas múltiples

Cuando importas el archivo FBX en Substance Painter, solo deberías ver un conjunto de texturas:

Los conjuntos de texturas están listados en el panel Listado de conjunto de texturas.

Si ves más de un conjunto significa que uno de los conjuntos tenía un error cuando se exportó la malla desde Blender

  • La malla no se combinó en un solo objeto.
  • La malla tenía más de una textura asignada.

De ser así, exporta tu modelo de Blender de nuevo y asegúrate de que la malla sea un objecto único y que solo tenga una textura asignada.

Exportar el archivo glTF a partir de Substance Painter

  1. Haz clic en File > Export Textures.
  2. A partir del menú desplegable Config, selecciona glTF PBR Metal Roughness.
  3. Selecciona el lugar donde deseas guardar tus texturas.
  4. Selecciona un tamaño de documento para determinar la dimensión de los archivos de textura.
  1. Haz clic en Exportar.

Comprimir archivos de textura

Una vez que hayas exportado el modelo deberías tener los siguientes archivos:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Cuando usas la configuración glTF PBR Metal Roughness, Substance Painter exporta solo los archivos de textura en formato PNG. Considera comprimir los archivos de textura y convertir cualquier textura que no necesite un canal alfa para un JPG. Esto reduce el tamaño total del archivo, y mientras más pequeño sea el archivo, mayor será la velocidad de descarga y mejor serán las interacciones.

Es mejor mantener un tamaño de archivo de 4MB o inferior.

Crear un archivo GLB

  1. Visita https://glb-packer.glitch.me/
  2. Arrastra y suelta los archivos que exportaste de Substance Painter en la página web de GLB Packer.

Se descargará un archivo llamado out.glb en tu computador. Una vez completada la descarga, cambia el nombre del archivo y súbelo a Shopify.

¿Estas listo(a) para comenzar a vender con Shopify?

Pruébala gratis