Blender ve Substance Painter kullanarak GLB dosyaları oluşturma

2.8 sürümünden itibaren Blender, Shopify yöneticisindeki bir ürüne eklenebilen GLB dosyalarını dışa aktarabiliyor. Daha fazla bilgi edinmek için Blender kılavuzuna bakın.

Blender'ın eski sürümleri için, bir GLB dosyasını dışa aktarmak üzere Blender'ı ve Substance Painter'ı birleştirebilirsiniz.

Blender'da modelinizi dışa aktarma için hazırlama

Modelinizi dışa aktarma için hazırlamak üzere tek bir mesh olduğundan ve üzerine tek bir dokunun uygulandığından emin olmanız gerekir.

Adımlar:

  1. Dosya > İçe aktar'a tıklayın ve ardından modeliniz için doğru dosya biçimini seçin.
  2. Model dosyanızı seçin ve ardından İçe aktar'a tıklayın.
  3. SHIFT tuşunu basılı tutarken görüntülediğiniz her nesneye sağ tıklayın ve ardından bunları tek bir mesh halinde birleştirmek için Ctrl + J tuşlarına basın.
  4. Modeli 0-1 UV alanına açın. UV'lerin örtüşmediğinden emin olun:
    UV/Görüntü Düzenleyicisinde tüm UV'erin ızgara üzerine yerleştirildiğinden emin olun.
  5. Özellikler düzenleyicisinde malzemeler simgesine tıklayın.
  6. Yeni bir malzeme yuvası eklemek için + düğmesine basın:
  7. Yeni'ye tıklayın.

Blender'dan mesh'i dışa aktarma

  1. Dosya > Dışa aktar > FBX (.fbx) seçeneğine tıklayın.
  2. Dosyayı dışa aktarmak istediğiniz yolu girin.
  3. Aşağıdaki dışa aktarma ayarlarını kullandığınızdan emin olun:
    Sürüm: FBX 7.4 ikili. Ölçek: 1,0. Ölçeklendirmeleri Uygula: Tümü Yerel. İleri: -Z İleri. Yukarı: Y Yukarı. Yol Modu: Otomatik. Toplu İş Modu: Kapalı.
  4. FBX dışa aktar'a tıklayın.

FBX dosyasını Substance Painter'da içe aktarma ve hazırlama

  1. File > New seçeneklerine tıklayarak yeni bir Substance Painter projesi oluşturun.
  2. New project iletişim kutusunda mesh seçmek için Select seçeneğine tıklayın.
  3. Blender yazılımından dışa aktardığınız FBX dosyasını seçip Open seçeneğine tıklayın.
  4. New project penceresinde OK seçeneğine tıklayın.
  5. Texture set list panelinde yalnızca bir doku kümesi olduğundan emin olarak mesh'inizi düzgün şekilde dışa aktardığınızı doğrulayın.

    Birden fazla doku kümesi görüyorsanız Birden fazla doku kümesi bölümüne bakın.

  6. Texture set settings panelinde, kanal eklemek için + düğmesine tıklayın:

    + düğmesi Channels başlığının yanındadır. Düğme, kullanılabilen ek kanalları gösteren bir açılır menü açar.

- Gerekli: Ambient occlusion. - İsteğe bağlı: Emissive. Modelinizde ışık yayan bileşenler varsa bu kanalı ekleyin. - İsteğe bağlı: Opacity. Modelinizde şeffaf olacak bileşenler varsa bu kanalı ekleyin.

  1. Texture set settings panelinde Bake Mesh Maps seçeneğine tıklayın.

  2. Dokuları modelin üzerine boyayın.

Birden fazla doku kümesi

FBX dosyasını Substance Painter'a aktardığınızda yalnızca bir doku kümesi görmeniz gerekir:

Doku kümeleri, Texture set list panelinde listelenir.

Birden fazla doku kümesi görüyorsanız mesh, Blender yazılımından dışa aktarılırken aşağıdaki sorunlardan biri oluşmuştur:

  • Mesh, tek bir nesnede birleştirilmemiş.
  • Mesh'e birden fazla doku atanmış.

Böyle bir durum söz konusuysa modelinizi Blender yazılımından tekrar dışa aktarın. Ardından mesh'in tek bir nesne olduğundan ve kendisine yalnızca tek dokunun atandığından emin olun.

Substance Painter'dan glTF dosyasını dışa aktarma

  1. File > Export Textures seçeneğine tıklayın.
  2. Config açılır menüsünden glTF PBR Metal Roughness'ı seçin.
  3. Dokularınızı kaydetmek istediğiniz konumu seçin.
  4. Doku dosyalarının ne kadar geniş olacağını belirlemek için bir belge boyutu seçin.

İpucu: Genellikle dokuların 2048 x 2048 pikselden daha geniş olması gerekmez. Toplam dosya boyutunu önemli ölçüde azaltmak için, mümkün olduğu durumlarda 1024 x 1024 piksel ölçüsünü kullanın.

  1. Dışa aktar'a tıklayın.

Doku dosyalarını sıkıştırma

Modeli dışa aktardığınızda aşağıdaki dosyaları elde edersiniz:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

glTF PBR Metal Roughness yapılandırmasını kullandığınızda Substance Painter, doku dosyalarını yalnızca PNG biçiminde dışa aktarır. Doku dosyalarını sıkıştırmayı ve alfa kanala ihtiyaç duymayan tüm dokuları JPG'ye dönüştürmeyi deneyin. Bu, toplam dosya boyutunu azaltır. Daha küçük dosya boyutu da daha yüksek indirme hızlarına ve daha sorunsuz etkileşimlere olanak sağlar.

Dosya boyutunuzu maksimum 4 MB ile sınırlı tutmanız önerilir.

GLB dosyası oluşturma

Not: PNG görsellerinizi JPG olarak değiştirirseniz glTF'i GLB olarak paketlemeniz için okunabilir glTF dosyasını düzenlemeniz ve gerekli PNG referanslarını JPG olarak değiştirmeniz gerekir. glTF dosyasını bir metin düzenleyicisinde açın, PNG biçimindeki tüm dosya adlarını JPG olarak güncelleyin ve ardından dosyayı kaydedin.

  1. https://glb-packer.glitch.me/ adresini ziyaret edin.
  2. Substance Painter'dan dışa aktardığınız dosyaları sürükleyip GLB Packer web sayfasına bırakın.

Bilgisayarınıza out.glb adında bir dosya indirilir. İndirme tamamlandıktan sonra dosyayı yeniden adlandırıp Shopify'a yükleyebilirsiniz.