3ds Max ve Substance Painter kullanarak GLB dosyaları oluşturma

Shopify yöneticisindeki bir ürüne eklenebilen bir GLB dosyasını dışa aktarmak için 3ds Max ve Substance Painter kullanın.

3ds Max'te modelinizi dışa aktarma için hazırlama

Modelinizi dışa aktarma için hazırlamak üzere tek bir mesh olduğundan ve üzerine tek bir malzemenin uygulandığından emin olmanız gerekir.

Adımlar:

  1. Dosya > İçe aktar... > İçe aktar... seçeneğine tıklayın.
  2. Model dosyanızı seçin ve ardından 'a tıklayın.
  3. OBJ İçe Aktarma Seçenekleri iletişim kutusunda, Tek bir mesh olarak içe aktar seçeneğini işaretleyin.
  4. İçe aktar'a tıklayın.
  5. Modeli 0-1 alanına açın. UV'lerin örtüşmediğinden emin olun:
    X ve Y eksenlerinde 0 ile 1 arasında UV'leri düzenlemek için
  6. Tüm modele tek bir malzeme uygulayın.

Mesh'i 3ds Max'ten dışa aktarma

  1. Dosya > Dışa aktar > Dışa aktar... seçeneğine tıklayın.
  2. Dosya adını ve modeli dışa aktarmak istediğiniz konumu girin.
  3. Kayıt türü açılır menüsünden OBJ-Export (.OBJ) seçeneğini belirleyin.
  4. Kaydet'e tıklayın.
  5. Obj Dışa Aktarma Seçenekleri iletişim kutusunda, varsayılan seçenekleri oldukları gibi bırakın ve Dışa aktar'a tıklayın.

OBJ dosyasını Substance Painter'da içe aktarma ve hazırlama

  1. File > New seçeneklerine tıklayarak yeni bir Substance Painter projesi oluşturun.
  2. New project iletişim kutusunda mesh seçmek için Select seçeneğine tıklayın.
  3. 3ds Max yazılımından dışa aktardığınız OBJ dosyasını seçip Open seçeneğine tıklayın.
  4. New project penceresinde OK seçeneğine tıklayın.
  5. Texture set list panelinde yalnızca bir doku kümesi olduğundan emin olarak mesh'inizi düzgün şekilde dışa aktardığınızı doğrulayın.

    Birden fazla doku kümesi görüyorsanız Birden fazla doku kümesi bölümüne bakın.

  6. Texture set settings panelinde, kanal eklemek için + düğmesine tıklayın:

    + düğmesi Channels başlığının yanındadır. Düğme, kullanılabilen ek kanalları gösteren bir açılır menü açar.

- Gerekli: Ambient occlusion. - İsteğe bağlı: Emissive. Modelinizde ışık yayan bileşenler varsa bu kanalı ekleyin. - İsteğe bağlı: Opacity. Modelinizde şeffaf olacak bileşenler varsa bu kanalı ekleyin.

  1. Texture set settings panelinde Bake Mesh Maps seçeneğine tıklayın.

  2. Dokuları modelin üzerine boyayın.

Birden fazla doku kümesi

OBJ dosyasını Substance Painter'a aktardığınızda yalnızca bir doku kümesi görmeniz gerekir:

Doku kümeleri, Texture set list panelinde listelenir.

Birden fazla doku kümesi görüyorsanız mesh, 3ds Max yazılımından dışa aktarılırken aşağıdaki sorunlardan biri oluşmuştur:

  • Mesh, tek bir nesnede birleştirilmemiş.
  • Mesh'e birden fazla doku atanmış.

Böyle bir durum söz konusuysa modelinizi 3ds Max yazılımından tekrar dışa aktarın. Ardından mesh'in tek bir nesne olduğundan ve kendisine yalnızca tek dokunun atandığından emin olun.

Substance Painter'dan glTF dosyasını dışa aktarma

  1. File > Export Textures seçeneğine tıklayın.
  2. Config açılır menüsünden glTF PBR Metal Roughness'ı seçin.
  3. Dokularınızı kaydetmek istediğiniz konumu seçin.
  4. Doku dosyalarının ne kadar geniş olacağını belirlemek için bir belge boyutu seçin.

İpucu: Genellikle dokuların 2048 x 2048 pikselden daha geniş olması gerekmez. Toplam dosya boyutunu önemli ölçüde azaltmak için, mümkün olduğu durumlarda 1024 x 1024 piksel ölçüsünü kullanın.

  1. Dışa aktar'a tıklayın.

Doku dosyalarını sıkıştırma

Modeli dışa aktardığınızda aşağıdaki dosyaları elde edersiniz:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

glTF PBR Metal Roughness yapılandırmasını kullandığınızda Substance Painter, doku dosyalarını yalnızca PNG biçiminde dışa aktarır. Doku dosyalarını sıkıştırmayı ve alfa kanala ihtiyaç duymayan tüm dokuları JPG'ye dönüştürmeyi deneyin. Bu, toplam dosya boyutunu azaltır. Daha küçük dosya boyutu da daha yüksek indirme hızlarına ve daha sorunsuz etkileşimlere olanak sağlar.

Dosya boyutunuzu maksimum 4 MB ile sınırlı tutmanız önerilir.

GLB dosyası oluşturma

Not: PNG görsellerinizi JPG olarak değiştirirseniz glTF'i GLB olarak paketlemeniz için okunabilir glTF dosyasını düzenlemeniz ve gerekli PNG referanslarını JPG olarak değiştirmeniz gerekir. glTF dosyasını bir metin düzenleyicisinde açın, PNG biçimindeki tüm dosya adlarını JPG olarak güncelleyin ve ardından dosyayı kaydedin.

  1. https://glb-packer.glitch.me/ adresini ziyaret edin.
  2. Substance Painter'dan dışa aktardığınız dosyaları sürükleyip GLB Packer web sayfasına bırakın.

Bilgisayarınıza out.glb adında bir dosya indirilir. İndirme tamamlandıktan sonra dosyayı yeniden adlandırıp Shopify'a yükleyebilirsiniz.