Crear archivos GLB utilizando 3D Max y Substance Painter

Usa 3ds Max y Substance Painter para exportar un archivo GLB que pueda agregarse a un producto en el panel de control de Shopify.

Preparar tu modelo para exportalo en 3ds Max

Para preparar tu modelo para exportarlo, debes asegurarte de que se trata de una malla única y de que tiene un solo material aplicado.

Pasos

  1. Haz clic en Archivo > Importar... > Importar...
  2. Selecciona tu archivo de modelo, y luego haz clic en Abrir.
  3. En el cuadro de diálogo Opciones de importación de OBJ, marca Importar como una sola malla.
  4. Haz clic en Importar.
  5. Despliega el modelo en el espacio 0-1. Asegúrate de que los rayos UV no se solapen:
    Utiliza el editor Edit UVWs para diseñar los UV entre 0 y 1 en los ejes X e Y.
  6. Aplica un solo material a todo el modelo.

Exportar la malla de 3ds Max

  1. Haz clic en Archivo > Exportar > Exportar...
  2. Introduce un nombre de archivo y la ubicación donde quieres exportar el modelo.
  3. En el menú desplegable Guardar como tipo selecciona OBJ-Export (.OBJ).
  4. Haz clic en Guardar.
  5. En el cuadro de diálogo Opciones de exportación de OBJ deja las opciones predeterminadas tal y como se encuentran y haz clic en Exportar.

Importar y preparar el archivo OBJ en Substance Painter

  1. Crea un nuevo proyecto en Substance Painter haciendo clic en File > New.
  2. En el cuadro de diálogo New project, haz clic en Select para elegir una malla (mesh).
  3. Selecciona el archivo OBJ que exportaste de 3ds Max y haz clic en Open.
  4. En la ventana New project, haz clic en OK.
  5. Verifica que exportaste correctamente tu malla verificando que solo haya un conjunto de textura en el panel de Texture set list.

    Si ves más de un conjunto de texturas, consulta Multiple texture sets.

  6. En el panel de Texture set settings, haz clic en el botón + para agregar canales:

    El botón + se encuentra al lado del título Channels. El botón abre un menú desplegable que muestra los canales adiciones disponibles.

- Obligatorio: Ambient occlusion. - Opcional: Emissive Agregar este canal si tu modelo tiene componentes que emiten luz. - Opcional: Opacity Agrega este canal si tu modelo tiene componentes transparentes.

  1. En el panel Texture set settings, haz clic en Bake Mesh Maps.

  2. Pintar texturas en el modelo.

Conjuntos de texturas múltiples

Cuando importas el archivo OBJ en Substance Painter, solo deberías ver un conjunto de texturas:

Los conjuntos de texturas están listados en el panel Listado de conjunto de texturas.

Si ves más de un conjunto significa que uno de los conjuntos tenía un error cuando se exportó la malla desde 3ds Max

  • La malla no se combinó en un solo objeto.
  • La malla tenía más de una textura asignada.

De ser así, exporta tu modelo de 3ds Max de nuevo y asegúrate de que la malla sea un objecto único y que solo tenga una textura asignada.

Exportar el archivo glTF a partir de Substance Painter

  1. Haz clic en File > Export Textures.
  2. A partir del menú desplegable Config, selecciona glTF PBR Metal Roughness.
  3. Selecciona el lugar donde deseas guardar tus texturas.
  4. Selecciona un tamaño de documento para determinar la dimensión de los archivos de textura.
  1. Haz clic en Exportar.

Comprimir archivos de textura

Una vez que hayas exportado el modelo deberías tener los siguientes archivos:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Cuando usas la configuración glTF PBR Metal Roughness, Substance Painter exporta solo los archivos de textura en formato PNG. Considera comprimir los archivos de textura y convertir cualquier textura que no necesite un canal alfa para un JPG. Esto reduce el tamaño total del archivo, y mientras más pequeño sea el archivo, mayor será la velocidad de descarga y mejor serán las interacciones.

Es mejor mantener un tamaño de archivo de 4MB o inferior.

Crear un archivo GLB

  1. Visita https://glb-packer.glitch.me/
  2. Arrastra y suelta los archivos que exportaste de Substance Painter en la página web de GLB Packer.

Se descargará un archivo llamado out.glb en tu computador. Una vez completada la descarga, cambia el nombre del archivo y súbelo a Shopify.

¿Estas listo(a) para comenzar a vender con Shopify?

Pruébala gratis