Criar arquivos GLB usando o 3ds Max e o Substance Painter

Use o 3ds Max e o Substance Painter para exportar um arquivo GLB que possa ser carregado para o 3D Warehouse.

Prepare seu modelo para exportação no 3ds Max

Para preparar seu modelo para exportação, você precisa ter certeza de que é uma malha única e que tem um único material aplicado a ela.

Etapas:

  1. Clique em Arquivo > Importar... > Importar...
  2. Selecione o seu arquivo de modelo e clique em Abrir.
  3. Na caixa de diálogo Opções de importação do OBJ, marque Importar como malha única.
  4. Clique em Importar.
  5. Desembrulhe o modelo no espaço 0-1. Certifique-se de que nenhum UV se sobreponha:
    Use o editor Editar UVWs para dispor os UVs entre 0 e 1 nos eixos X e Y.
  6. Aplique um único material ao modelo inteiro.

Exportar a malha do 3ds Max

  1. Clique em Arquivo > Exportar > Exportar...
  2. Digite um nome de arquivo e o local onde você deseja exportar o modelo.
  3. No menu suspenso Salvar como tipo, selecione OBJ-Exportar (.OBJ).
  4. Clique em Save.
  5. Na caixa de diálogo Opções de exportação de OBJ, deixe as opções padrão como estão e clique em Exportar.

Importar e preparar o arquivo OBJ no Substance Painter

  1. Crie um novo projeto no Substance Painter ao clicar em File (Arquivo) > New (Novo).
  2. Na caixa de diálogo New project (Novo projeto), clique em Select (Selecionar) para escolher uma malha.
  3. Selecione o arquivo OBJ que você exportou do 3ds Max e, depois, clique em Open (Abrir).
  4. Na janela New project (Novo projeto), clique em OK.
  5. Verifique se você exportou sua malha corretamente ao conferir se há apenas um conjunto de textura no painel Texture set list (Lista de conjunto de textura).

    Se você visualizar mais de um conjunto de textura, acesse Multiple texture sets (Vários conjuntos de textura).

  6. No painel Texture set settings (Configurações do conjunto de textura), clique no botão + para adicionar canais:

    O botão + está ao lado do título Channels (Canais). Ele abre um menu suspenso que exibe os canais adicionais disponíveis.

- Obrigatório: Ambient occlusion (Oclusão de ambiente). - Opcional: Emissive (Emissão de luz). Adicione esse canal se seu modelo apresenta componentes que emitem luz. - Opcional: Opacity (Opacidade). Adicione esse canal se seu modelo apresenta componentes que serão transparentes.

  1. No painel Texture set settings (Configurações do conjunto de textura, clique em Bake Mesh Maps (Bake mapas de malha).

  2. Pinte as texturas no modelo.

Vários conjuntos de textura

Ao importar o arquivo OBJ para o Substance Painter, você deve visualizar apenas um conjunto de textura:

Os conjuntos de textura são listados no painel Texture set list (Lista de conjunto de textura).

Se você visualizar mais de um conjunto de textura, o arquivo apresentava um dos seguintes erros quando a malha foi exportada do 3ds Max:

  • A malha não foi consolidada em um único objeto.
  • Mais de uma textura foi atribuída à malha.

Se esse for o caso, exporte seu modelo do 3ds Max novamente e certifique-se de que a malha é um único objeto e apresenta apenas uma textura atribuída a ela.

Exportar o arquivo glTF do Substance Painter

  1. Clique em Arquivo (File) > Exportar texturas (Export Textures).
  2. No menu suspenso Config, selecione glTF PBR Metal Roughness.
  3. Escolha o local onde você deseja salvar suas texturas.
  4. Escolha o tamanho do documento para determinar o tamanho dos arquivos de textura.
  1. Clique em Exportar.

Compressão de arquivos de textura

Após exportar o modelo, você deverá ter os seguintes arquivos:

  • NomeDoModelo.bin
  • NomeDoModelo.glb
  • NomeDoModelo.gltf
  • NomeDoModelobaseColor.png
  • NomeDoModelonormal.png
  • NomeDoModelo_occlusionRoughnessMetallic.png

Se você usar a configuração glTF PBR Metal Roughness, o Substance Painter só exportará os arquivos de textura no formato PNG. Avalie a possibilidade de compactar os arquivos de textura e converter para JPG todas as texturas que não precisem do canal alfa. Isso reduz o tamanho total do arquivo, e arquivos menores proporcionam velocidades de download mais rápidas e interações mais fluidas.

Convém manter o tamanho de seus arquivos até no máximo 3 MB.

Criar um arquivo GLB

  1. Acesse https://glb-packer.glitch.me/.
  2. No site GLB Packer, arraste e solte os arquivos que você exportou do Substance Painter.

Um arquivo com o nome out.glb será baixado para seu computador. Após a conclusão do download, você pode renomear o arquivo e, depois, carregá-lo para o 3D Warehouse.

Pronto(a) para começar a vender com a Shopify?

Experimente de graça