Criar arquivos GLB usando o Blender e o Substance Painter

Use o Blender e o Substance Painter para exportar um arquivo GLB que possa ser carregado para o 3D Warehouse.

Prepare seu modelo para exportação no Blender

Para preparar seu modelo para exportação, você precisa ter certeza de que é uma malha única e que tem um único material aplicado a ela.

Etapas:

  1. Clique em Arquivo > Importar e selecione o formato de arquivo correto para o seu modelo.
  2. Selecione o seu arquivo de modelo e clique em Importar.
  3. Segurando SHIFT, clique com o botão direito em cada objeto em sua cena e pressione Ctrl + J para juntá-los em uma malha.
  4. Desembrulhe o modelo no espaço 0-1. Certifique-se de que nenhum UV se sobreponha:
    No UV/Image Editor, certifique-se de que todos os UVs estão dispostos na grade.
  5. No editor de Propriedades, clique no ícone de materiais.
  6. Clique no botão + para adicionar um novo slot de material:
    O botão 'Adicionar um slot de material' está perto do topo do painel 'Material'.
  7. Clique em Novo.

Exportar a malha do Blender

  1. Clique em Arquivo > Exportar > FBX (.fbx).
  2. Digite o caminho para onde você deseja exportar o arquivo.
  3. Certifique-se de usar as seguintes configurações de exportação:
    Versão: FBX 7.4 vinária. Escala: 1.0. Aplicar escalonamento: todo local. Avançar: -Z avançado. Acima: Y acima. Modo de caminho: auto. Modo de batch: des.
  4. Clique em Exportar FBX.

Importar e preparar o arquivo FBX no Substance Painter

  1. Crie um novo projeto no Substance Painter ao clicar em File (Arquivo) > New (Novo).
  2. Na caixa de diálogo New project (Novo projeto), clique em Select (Selecionar) para escolher uma malha.
  3. Selecione o arquivo FBX que você exportou do Blender e, depois, clique em Open (Abrir).
  4. Na janela New project (Novo projeto), clique em OK.
  5. Verifique se você exportou sua malha corretamente ao conferir se há apenas um conjunto de textura no painel Texture set list (Lista de conjunto de textura).

    Se você visualizar mais de um conjunto de textura, acesse Multiple texture sets (Vários conjuntos de textura).

  6. No painel Texture set settings (Configurações do conjunto de textura), clique no botão + para adicionar canais:

    O botão + está ao lado do título Channels (Canais). Ele abre um menu suspenso que exibe os canais adicionais disponíveis.

- Obrigatório: Ambient occlusion (Oclusão de ambiente). - Opcional: Emissive (Emissão de luz). Adicione esse canal se seu modelo apresenta componentes que emitem luz. - Opcional: Opacity (Opacidade). Adicione esse canal se seu modelo apresenta componentes que serão transparentes.

  1. No painel Texture set settings (Configurações do conjunto de textura, clique em Bake Mesh Maps (Bake mapas de malha).

  2. Pinte as texturas no modelo.

Vários conjuntos de textura

Ao importar o arquivo FBX para o Substance Painter, você deve visualizar apenas um conjunto de textura:

Os conjuntos de textura são listados no painel Texture set list (Lista de conjunto de textura).

Se você visualizar mais de um conjunto de textura, o arquivo apresentava um dos seguintes erros quando a malha foi exportada do Blender:

  • A malha não foi consolidada em um único objeto.
  • Mais de uma textura foi atribuída à malha.

Se esse for o caso, exporte seu modelo do Blender novamente e certifique-se de que a malha é um único objeto e apresenta apenas uma textura atribuída a ela.

Exportar o arquivo glTF do Substance Painter

  1. Clique em Arquivo (File) > Exportar texturas (Export Textures).
  2. No menu suspenso Config, selecione glTF PBR Metal Roughness.
  3. Escolha o local onde você deseja salvar suas texturas.
  4. Escolha o tamanho do documento para determinar o tamanho dos arquivos de textura.
  1. Clique em Exportar.

Compressão de arquivos de textura

Após exportar o modelo, você deverá ter os seguintes arquivos:

  • NomeDoModelo.bin
  • NomeDoModelo.glb
  • NomeDoModelo.gltf
  • NomeDoModelobaseColor.png
  • NomeDoModelonormal.png
  • NomeDoModelo_occlusionRoughnessMetallic.png

Se você usar a configuração glTF PBR Metal Roughness, o Substance Painter só exportará os arquivos de textura no formato PNG. Avalie a possibilidade de compactar os arquivos de textura e converter para JPG todas as texturas que não precisem do canal alfa. Isso reduz o tamanho total do arquivo, e arquivos menores proporcionam velocidades de download mais rápidas e interações mais fluidas.

Convém manter o tamanho de seus arquivos até no máximo 3 MB.

Criar um arquivo GLB

  1. Acesse https://glb-packer.glitch.me/.
  2. No site GLB Packer, arraste e solte os arquivos que você exportou do Substance Painter.

Um arquivo com o nome out.glb será baixado para seu computador. Após a conclusão do download, você pode renomear o arquivo e, depois, carregá-lo para o 3D Warehouse.

Pronto(a) para começar a vender com a Shopify?

Experimente de graça