Het maken van GLB-bestanden met behulp van Maya en Substance Painter

Gebruik Maya en Substance Painter om een GLB-bestand te exporteren dat kan worden toegevoegd aan een product in het Shopify-beheercentrum.

Uw model voorbereiden op export in Maya

Als u uw model wilt voorbereiden op export, moet u ervoor zorgen dat het een enkel mesh is en dat er één enkel materiaal op wordt toegepast.

Stappen:

  1. Importeer uw model in Maya door naar Bestand > Importeren... te gaan, uw 3D-bestand te kiezen en vervolgens op Importeren te klikken.
  2. Klik op Mesh > Combineren om uw mesh tot een enkel object te combineren.
  3. Pak het model uit in 0-1-UV-ruimte. Zorg ervoor dat er geen UV's overlappen:
    Gebruik de UV-editor om de UV's tussen 0 en 1 op de X- en Y-assen op te maken.
  4. Een Phong-materiaal op het model toepassen:
    1. Plaats je muiscursor boven het model, klik met de rechtermuisknop en houd deze vast en selecteer vervolgens Nieuw materiaal toewijzen...
    2. Selecteer Phong in het dialoogvenster.

Het mesh exporteren vanuit Maya

  1. Selecteer het volledige mesh en klik vervolgens op Bestand > Selectie exporteren...
  2. Voer een bestandsnaam en de locatie waar het bestand moet worden opgeslagen in.
  3. Selecteer OBJexport in het vervolgkeuzemenu Bestandstype.
  4. Klik op Selectie exporteren.

Importeer en bewerk het OBJ bestand in Substance Painter

  1. Maak een nieuw Substance Painter-project door te klikken op Bestand > Nieuw.
  2. Klik in het dialoogvenster Nieuw project op Selecteren om een mesh te kiezen.
  3. Selecteer het OBJ bestand dat u uit Maya hebt geëxporteerd en klik op Openen.
  4. Klik in het dialoogvenster Nieuw project op Ok.
  5. Controleer of je je mesh correct hebt geëxporteerd door te controleren of er slechts één textuur is ingesteld in het deelvenster Textuursetinstellingen.

    Als er meer dan één textuur is ingesteld, gaat u naar Meerdere textuursets.

  6. Klik in het deelvenster*Textuursetinstellingen* op de +-knop om kanalen toe te voegen:

    De knop + staat naast de kop Kanalen. Met deze knop wordt een vervolgkeuzemenu geopend met extra beschikbare kanalen.

- Vereist: Ambient occlusion. - Optioneel: Uitstralend. Voeg dit kanaal toe als je model componenten bevat die licht zullen uitstralen. - Optioneel: Ondoorschijnend. Voeg dit kanaal toe als uw model componenten bevat die transparant zullen zijn.

  1. Klik in het deelvenster Textuursetinstellingen op Bake Mesh Maps.

  2. Schildertextuur op het model.

Meerdere textuursets

Als je het bestand OBJ importeerd in Substance Painter, krijgt je slechts één textuurset te zien:

De textuursets worden weergegeven in het deelvenster Textuursetinstellingen.

Als er meer dan één textuurset is ingesteld, was een van de volgende verkeerd toen de mesh werd geëxporteerd uit Maya:

  • De mesh is niet gecombineerd tot één object.
  • Er is meer dan één textuur toegewezen aan de mesh.

Exporteer in dit geval uw model opnieuw uit Maya en zorg dat de mesh één object is met slechts één toegewezen textuur.

Exporteer het gITF-bestand uit Substance Painter

  1. Klik op Bestand > Texturen exporteren.
  2. Selecteer uit het vervolgkeuzemenu Config de optie glTF PBR Metal Roughness.
  3. Kies de locatie waar u uw texturen wilt opslaan.
  4. Kies een documentgrootte om te bepalen hoe groot de textuurbestanden zullen zijn.
  1. Klik op Exporteren.

Textuurbestanden comprimeren

Wanneer je het model hebt geëxporteerd, zou je de volgende bestanden moeten hebben:

  • modelName.bin
  • naamModel.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • naamModel_occlusionRoughnessMetallic.png

Als u de configuratie glTF PBR Metal Roughness gebruikt, zal Substance Painter de textuurbestanden alleen exporteren in PNG-formaat. Probeer de textuurbestanden te comprimeren en texturen die geen alfakanaal nodig hebben om te zetten naar een JPG. Hierdoor wordt de totale bestandsgrootte kleiner en met kleinere bestanden kunt u sneller downloaden en is de interactie soepeler.

Het is het beste om het bestand niet groter dan 4 MB te maken.

Een GLB-bestand creëren

  1. Ga naar https://glb-packer.glitch.me/.
  2. Sleep de bestanden die u uit Substance Painter hebt geëxporteerd naar de GLB Packer-webpagina.

Er wordt een bestand met de naam out.glb gedownload naar uw computer. Nadat de download is voltooid, kunt u het bestand hernoemen en vervolgens uploaden naar Shopify.

Klaar om te beginnen met verkopen met Shopify?

Probeer het gratis