GLB-tiedostojen luominen Mayassa ja Substance Painterissa

Käytä Maya- ja Substance Painter -ohjelmia GLB-tiedoston vientiin, jos haluat lisätä sen tuotteeseen Shopify adminissa.

Mallin valmisteleminen vientiä varten Mayassa

Kun valmistelet malliasi vietäväksi, sinun täytyy varmistaa, että kyseessä on yksittäinen verkkorakenne, ja että siihen on lisätty yksi materiaali.

Toimintovaiheet:

  1. Tuo malli Mayaan siirtymällä File > Import... ja valitse sitten 3D-tiedosto ja klikkaa Import.
  2. Yhdistä verkkorakenne yhdeksi objektiksi napauttamalla Mesh > Combine.
  3. Kartoita malli 0-1 UV-tilaan. Varmista, etteivät UV:t ole päällekkäisiä:
    Aseta UV-editorilla UV:t 0:n ja 1:n ja X- ja Y-akselien välille.
  4. Phong-materiaalin käyttäminen mallissa:
    1. klikkaa hiiren oikeaa painiketta ja pidä se painettuna, kun hiiren osoitin on mallin päällä, ja valitse sitten Assign New Material...
    2. Valitse valintaikkunassa Phong.

Verkkorakenteen vieminen Mayasta

  1. Valitse koko verkkorakenne ja klikkaa sen jälkeen File > Export Selection...
  2. Anna tiedostonimi ja sijainti, jonne tiedosto tallennetaan.
  3. Valitse Files of type -alasvetovalikosta OBJexport.
  4. klikkaa Export Selection.

Tiedoston tuominen ja valmisteleminen OBJ Substance Painter -ohjelmassa

  1. Luo uusi Substance Painter -projekti valitsemalla File > New.
  2. Valitse verkko napauttamalla New project -valintaikkunassa Select.
  3. Valitse Maya-ohjelmasta viemäsi OBJ-tiedosto ja klikkaa Avaa.
  4. klikkaa New project -ikkunassa OK.
  5. Varmista, että verkko on viety oikein tarkistamalla, että Texture set list -paneelissa on vain yksi tekstuurisarja.

    Jos näet useamman kuin yhden tekstuurisarjan, katso Monta tekstuurisarjaa -sivua.

  6. Lisää kanavia napauttamalla Tekstuurisarjan asetukset -paneelissa +-painiketta:

    +-painike on Channels-otsikon vieressä. Painikkeesta avautuu alasvetovalikko, joka näyttää käytettävissä olevat lisäkanavat.

- Pakollinen: Ambient occlusion (ympäristön okkluusio). - Valinnainen: Emissive (emissiivinen). Jos mallissa on valoa säteileviä osia, lisää tämä kanava. - Valinnainen: Opacity (läpikuultamattomuus). Lisää tämä kanava, jos mallissa on läpinäkyviä osia.

  1. klikkaa Tekstuurisarjan asetukset -paneelissa Bake-verkkokartat.

  2. Maalaa malliin tekstuureja.

Monta tekstuurisarjaa

Kun tuot OBJ-tiedoston Substance Painter -ohjelmaan, näkyvissä pitäisi olla vain yksi tekstuurisarja:

Texture set -luettelopaneelissa on tekstuurisarjojen luettelo.

Jos näkyvissä on useampia kuin yksi tekstuurisarja, jompi kumpi seuraavista kohdista meni väärin, kun verkkoa vietiin Maya-ohjelmasta:

  • Verkkoa ei ollut yhdistetty yhdeksi objektiksi.
  • Verkkoon oli liitetty useampia kuin yksi tekstuuri.

Jos näin on, vie malli Maya-ohjelmasta ja varmista, että verkko on yksittäinen objekti ja että siihen on liitetty vain yksi tekstuuri.

Vie glTF-tiedosto Substance Painterista

  1. Valitse File > Export Textures.
  2. Valitse Config-alasvetovalikosta glTF PBR Metal Roughness.
  3. Valitse sijainti, johon haluat tallentaa tekstuurit.
  4. Valitse asiakirjan koko määrittääksesi, kuinka suuria tekstuuritiedostot ovat.
  1. Klikkaa Vie.

Tekstuuritiedostojen pakkaaminen

Kun olet siirtänyt mallin, sinulla pitäisi olla seuraavat tiedostot:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Kun käytät glTF PBR Metal Roughness -asetusta, Substance Painter vie tekstuuritiedostot vain PNG-muodossa. Harkitse tekstuuritiedostojen pakkaamista ja kaikkien sellaisten tekstuurien muuntamista JPG-muotoon, joissa ei tarvita alfa-kanavaa. Tämä pienentää tiedostojen kokoa, ja pienemmät tiedostokoot nopeuttavat latausta ja tekevät vuorovaikutuksesta jouhevampaa.

Tiedoston koko on hyvä olla enintään 3 Mt.

GLB-tiedoston luominen

  1. Mene osoitteeseen https://glb-packer.glitch.me/.
  2. Vedä ja pudota Substance Painterista viedyt tiedostot GLB Packerin verkkosivulle.

Tiedosto nimeltä out.glb ladataan tietokoneellesi. Kun lataus on valmis, voit nimetä tiedoston uudelleen ja ladata sen Shopifyihin.