Shopifyストアへの安全な接続を有効にする
Shopifyストアへの安全な接続を有効にすると、お客様が入力するデータは非公開かつ安全に処理されます。これは、SSL (Secure Sockets Layer) 証明書とも呼ばれる、TLS (Transport Layer Security) 証明書を使用して、ストアと外部コンテンツ間のコミュニケーションを暗号化し、HTTPではなくHTTPSを使用して安全にコンテンツを公開することで達成されます。
たとえば、ストアのURLがhttp://www.example.com
の場合、TLS証明書が発行されると、URLはhttps://www.example.com
に変更されます。お客様が元のURLを使用すると、暗号化されたオンラインストアに自動的にリダイレクトされます。
TLS証明書には、オンラインストアにとって次のメリットがあります。
- お客様データを暗号化することで、セキュリティのレベルが高まります。
- オンラインストアのURLの横に鍵マークが表示されるので、お客様の信頼を築くのに役立ちます。
TLS証明書を取得する
TLS証明書は、Shopifyに追加されたドメインすべてに対して無料で提供されます。TLS証明書は次の状況で自動的に発行されます。
-
.myshopify.com
ドメインでホストされているすべてのアセット。 - Shopifyからカスタムドメインを購入、またはドメインをShopifyに移管する場合。
- Shopifyを指定するようAレコードおよびCNAMEレコードを変更して、外部ドメインをShopifyに接続する場合。この場合、TLS証明書の発行に最長48時間かかることがあります。その間、管理画面のドメイン設定には、TLSまたはSSLが保留中と表示されることがあります。48時間が経過してもTLSが正常に動作しなかった場合、管理画面のドメイン設定には、TLSまたはSSLが利用できないことを示すメッセージが表示される可能性があります。48時間後に
Your connection is unsecure
のようなエラーメッセージがストアフロントに表示された場合は、トラブルシューティングの手順に従ってください。これらの手順でTLSの問題が解決しない場合は、Shopifyサポートにお問い合わせください。
TLS証明書が発行されたことは、[ドメイン] ページで、ドメインのステータスがConnected
になったことで確認できます。また、ストアフロントを見ると、アドレスバーのオンラインストアURLの横に鍵マークが表示されます。
アセットが安全か確認する
オンラインストアに、Shopify以外でホストされている画像、ビデオ、Webフォント、またはその他のアセットが含まれている場合、それらはHTTPS経由で配信される必要があります。HTTPS経由で配信されないアセットを含むShopifyオンラインストアのページは、安全ではないとみなされます。
アセットの安全性を確実にするための最善の方法は、オンラインストアのすべてのアセットをShopifyでホストすることです。
Shopify以外でアセットをホストする必要がある場合は、以下のことを実行してください。
- HTTPS経由で公開するサーバーで、アセットをホストします。管理画面にファイルをアップロードする方法について詳しくはこちらをご覧ください。
- HTTPS経由で公開するサービスで、ビデオコンテンツをホストします。
- Webフォントを使用する場合は、ソースからHTTPS経由で公開されていることを確認します。
認証局の承認 (CAA) レコード
認証局の承認 (CAA) レコードは、どの認証局がドメインの証明書を発行できるかを指定するために使用されます。認証局 (CA) とは、インターネット上のデジタルエンティティの身元証明の電子文書を発行する、公認団体を指します。
ストアでCAAレコードは必要ありません。CAAレコードの使用を要求される場合、ドメインをShopifyに接続すると同時に、以下の認証局 (CA) を各CAAレコードに追加する必要があります。
外部ドメインで発生するセキュリティエラーのトラブルシューティング
外部ドメインをShopifyに接続すると、お客様はオンラインストアにアクセスできなくなります。
現象
以下のエラーが発生します。
- 管理画面に、TLSまたはSSLの使用不可エラーか、
SSL pending
のようなメッセージが表示されます。 - ストアフロントに、
Your connection is unsecure
のようなメッセージが表示されます。
原因
外部サービスのドメインをShopifyに接続してからTLS証明書が発行されるまでに、最大48時間かかる場合があります。証明書が発行されるまでの間、管理画面にTLSまたはSSLの使用不可エラーか、SSL pending
のようなメッセージが表示される場合があります。48時間後もエラーが表示される場合、ドメインプロバイダーのサイトが正しく設定されていない可能性があります。
解決策
48時間経過しても、TLSまたはSSL使用不可エラーが表示されている場合は、以下の手順を実行します。
- Aレコードが
23.227.38.65
、AAAAレコードが2620:0127:f00f:5::
、CNAMEレコードがshops.myshopify.com
であることを確認します。 - CAAレコードを使用する場合は、必要なすべての認証局を追加したことを確認します。
- ドメインでDNSSECが有効になっている場合は、無効にします。
- Android 7.0以前を使用している場合は、デバイスをアップグレードする必要があります。
- 2010年より前のバージョンのブラウザを使用している場合は、最新バージョンに更新してください。
さらにサポートが必要な場合、Shopifyサポートにお問い合わせください。