Sichere Verbindungen zu deinem Shopify-Shop aktivieren
Das Aktivieren sicherer Verbindungen zu deinem Shopify-Shop stellt sicher, dass die von deinen Kunden eingegebenen Daten privat und sicher gehandhabt werden. Dies wird durch ein TLS (Transport Layer Security)-Zertifikat erreicht, das manchmal als SSL (Secure Sockets Layer)-Zertifikat bezeichnet wird und die Kommunikation zwischen deinem Shop und externen Inhalten verschlüsselt. Es veröffentlicht den Inhalt auf sichere Weise, da HTTPS anstelle von HTTP verwendet wird.
Wenn die URL deines Shops z. B. http://www.example.com
lautet, wird sie zu https://www.example.com
geändert, sobald das TLS-Zertifikat ausgestellt wird. Wenn deine Kunden die ursprüngliche URL verwenden, werden sie automatisch zum verschlüsselten Onlineshop weitergeleitet.
TLS-Zertifikate haben die folgenden Vorteile für deinen Onlineshop:
- Sie fügen eine Sicherheitsebene hinzu, indem sie Kundendaten verschlüsseln.
- Sie helfen dir dabei, Kundenvertrauen aufzubauen, indem ein Vorhängeschloss-Symbol neben der URL deines Onlineshops angezeigt wird.
Auf dieser Seite
Ein TLS-Zertifikat erhalten
TLS-Zertifikate werden kostenlos für alle Domains bereitgestellt, die zu Shopify hinzugefügt werden. In folgenden Fällen wird automatisch ein TLS-Zertifikat ausgestellt:
- Für alle Assets, die auf der
.myshopify.com
-Domain gehostet werden. - Wenn du eine benutzerdefinierte Domain über Shopify kaufst oder eine Domain zu Shopify überträgst.
- Wenn du deine Drittanbieter-Domain mit Shopify verbindest, indem du deinen A-Eintrag und deinen CNAME-Eintrag so änderst, dass sie auf Shopify verweisen. In diesem Fall kann es bis zu 48 Stunden dauern, bis das TLS-Zertifikat ausgestellt wird. Während dieser Zeit wird eventuell der Fehler "TLS oder SSL ausstehend" in den Domain-Einstellungen deines Shopify-Adminbereichs angezeigt. Wenn dein TLS-Zertifikat nach 48 Stunden nicht ausgestellt wurde, wird möglicherweise in den Domain-Einstellungen deines Shopify-Adminbereichs die Meldung "TLS oder SSL nicht verfügbar" angezeigt. Wenn nach 48 Stunden eine ähnliche Fehlermeldung wie
Your connection is unsecure
in deiner Storefront angezeigt wird, führe die Schritte zur Fehlerbehebung aus. Wenn diese Schritte die TLS-Probleme nicht beheben, wende dich an den Shopify Support.
Du kannst sicherstellen, dass dein TLS-Zertifikat ausgestellt wurde, indem du überprüfst, ob der Status der Domain auf der Seite der Domains Connected
lautet. Zusätzlich wird das Vorhängeschloss-Symbol neben der URL deines Onlineshops in der Adressleiste angezeigt, wenn du deine Storefront anzeigst.
Die Sicherheit deiner Assets überprüfen
Wenn dein Onlineshop Bilder, Videos, Webfonts oder andere Assets beinhaltet, die nicht auf Shopify gehostet werden, sollten diese per HTTPS bereitgestellt werden. Jede Seite in deinem Shopify-Onlineshop, die ein Asset beinhaltet, welches nicht über HTTPS bereitgestellt wird, gilt als unsicher.
Die beste Möglichkeit, die Sicherheit deiner Assets sicherzustellen, ist das Hosten all deiner Onlineshop-Assets auf Shopify.
Wenn du deine Assets außerhalb von Shopify hosten musst, stelle sicher, dass du das Folgende tust:
- Hoste deine Assets auf einem Server, der für die Veröffentlichung HTTPS verwendet. Mehr Informationen über das Hochladen von Dateien im Shopify-Adminbereich.
- Hoste deine Videoinhalte auf einem Dienst, der für die Veröffentlichung HTTPS verwendet.
- Bei der Verwendung von Webfonts solltest du sicherstellen, dass sie von der entsprechenden Quelle über HTTPS veröffentlicht werden.
Certification Authority Authorization (CAA)-Einträge
Ein Certification Authority Authorization (CAA)-Eintrag wird verwendet, um zu spezifizieren, welche Zertifikatsbehörden berechtigt sind, Zertifikate für eine Domain auszustellen. Eine Zertifikatsbehörde (CA) ist eine vertrauenswürdige Entität, die elektronische Dokumente ausstellt, die die Identität einer digitalen Entität im Internet verifizieren.
Du benötigst keine CAA-Einträge für deinen Shop. Wenn du jedoch CAA-Einträge verwenden musst, müssen die folgenden Zertifikatsbehörden (CA) zu jedem CAA-Eintrag hinzugefügt werden, was gleichzeitig mit der Verbindung deiner Domain mit Shopify geschehen muss:
Fehlerbehebung bei Sicherheitsfehlern bei deiner Drittanbieter-Domain
Nachdem du deine Drittanbieter-Domain mit Shopify verbunden hast, können deine Kunden nicht mehr auf deinen Onlineshop zugreifen.
Symptom
Die folgenden Fehler treten auf:
- Der Fehler "TLS oder SSL nicht verfügbar" oder
SSL pending
wird in deinem Shopify-Adminbereich angezeigt. - Eine Nachricht wie
Your connection is unsecure
wird auf deiner Storefront angezeigt.
Ursache
Es kann nach der Verbindung deiner Drittanbieter-Domain mit Shopify bis zu 48 Stunden dauern, bis das TLS-Zertifikat ausgestellt wird. Während dieser Zeit wird eventuell der Fehler "TLS oder SSL nicht verfügbar" oder SSL pending
in deinem Shopify-Adminbereich angezeigt. Wenn die Fehlermeldung nach 48 Stunden weiterhin besteht, sind die Einstellungen auf der Seite deines Domain-Providers möglicherweise nicht richtig konfiguriert.
Auflösung
Wenn der Fehler "TLS nicht verfügbar" oder "SSL nicht verfügbar" nach 48 Stunden immer noch angezeigt wird, führe die folgenden Schritte aus:
- Stelle sicher, dass dein A-Eintrag
23.227.38.65
ist, dein AAAA-Eintrag2620:0127:f00f:5::
ist und dein CNAME-Eintragshops.myshopify.com
ist. - Wenn du CAA-Einträge verwendest, stelle sicher, dass du alle erforderlichen Zertifizierungsstellen hinzugefügt hast.
- Wenn du DNSSEC für deine Domain aktiviert hast, deaktiviere die Option.
- Wenn du Android 7.0 oder niedriger verwendest, musst du ein Geräte-Upgrade durchführen.
- Wenn du eine Version deines Browsers aus der Zeit vor 2010 verwendest, aktualisiere deinen Browser auf die neueste Version.
Wenn du weitere Hilfe benötigst, wende dich an den Shopify Support.