Habilitar conexões seguras à loja da Shopify
Para garantir a proteção e a privacidade das informações fornecidas pelos clientes, é fundamental habilitar conexões seguras em sua loja da Shopify. Isso é feito usando um certificado TLS (Transport Layer Security), às vezes chamado de certificado SSL (Secure Sockets Layer). Ele criptografa a comunicação entre a loja e o conteúdo externo, bem como substitui o protocolo HTTP pelo HTTPS para trazer ainda mais segurança ao publicar o conteúdo.
Por exemplo, caso o URL da loja seja http://www.example.com
, ele será alterado para https://www.example.com
quando o Certificado TLS for emitido. Os clientes que usarem a forma antiga serão redirecionados automaticamente para a loja virtual criptografada.
Os certificados TLS oferecem os seguintes benefícios para a loja virtual:
- Eles criptografam os dados do cliente para adicionar uma camada de segurança.
- Eles exibem um ícone de cadeado ao lado do URL para aumentar a confiança dos clientes.
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Adquirir um certificado TLS
Os certificados TLS são fornecidos de forma gratuita e automática para os domínios adicionados à Shopify nas seguintes circunstâncias:
- Para todos os ativos hospedados no domínio
.myshopify.com
. - Quando você compra um domínio personalizado com a Shopify ou transfere um domínio para a plataforma.
- Quando você altera os registros A e CNAME para conectar um domínio de terceiros à Shopify. Nesse caso, pode levar até 48 horas para que o certificado TLS seja emitido. Enquanto isso, é possível que uma mensagem "TLS ou SSL pendente" seja exibida nas configurações do domínio do admin da Shopify. Após 48 horas, caso o TLS tenha falhado, talvez você receba uma mensagem "TLS ou SSL indisponível" nas configurações do domínio no admin da Shopify. Se você receber uma mensagem de erro semelhante a
Your connection is unsecure
na vitrine após 48 horas, tente as etapas de solução de problemas. Se essas etapas não solucionarem os problemas com o TLS, entre em contato com o Atendimento ao cliente da Shopify.
Para confirmar a emissão do certificado TLS, verifique se o domínio tem o status Connected
na página Domínios. Além disso, é importante conferir se o ícone de cadeado aparece ao lado do URL da vitrine virtual na barra de endereços ao visualizar a vitrine.
Verificar se os ativos estão seguros
Se a loja virtual inclui imagens, vídeos, fontes da web ou outros recursos não hospedados na Shopify, é necessário que tais conteúdos sejam veiculados em HTTPS para garantir a segurança das páginas. Vale lembrar que as páginas da loja virtual da Shopify que incluem algum recurso não entregue por HTTPS são consideradas inseguras.
Vale lembrar que a melhor opção para proteger a segurança dos ativos é hospedá-los na loja virtual da Shopify.
No entanto, caso isso não seja possível, é importante seguir as orientações abaixo:
- Hospedar os ativos em um servidor que publique em HTTPS. Saiba mais sobre como fazer upload de arquivos no admin da Shopify.
- Hospedar seu conteúdo de vídeo num serviço que publica por HTTPS.
- Caso use fontes da web, verifique se elas foram publicadas em HTTPS a partir da fonte.
Registros de Autorização de Autoridade Certificadora (CAA)
Os registros de Autorização de Autoridade Certificadora (CAA, na sigla em inglês) são usados para especificar as autoridades certificadoras que podem emitir certificados para domínios na Internet com identidade verificada.
A princípio, não é necessário ter registros de CAA na loja. Entretanto, caso sejam exigidos, adicione as autoridades certificadoras (CA) abaixo a cada um enquanto conecta o domínio à Shopify:
Como solucionar erros de segurança em domínios de terceiros
Depois de adicionar um domínio de terceiros à Shopify, os clientes não conseguem mais acessar a loja virtual.
Sintoma
Ocorrem os seguintes erros:
- Um aviso de erro "TLS ou SSL indisponível" ou
SSL pending
é exibido no admin da Shopify. - Uma mensagem semelhante a
Your connection is unsecure
é exibida na vitrine.
Causa
Pode levar até 48 horas para que o certificado TLS seja emitido depois que você conectar seu domínio de terceiros à Shopify. Enquanto isso, é possível que um erro "TLS ou SSL indisponível" ou SSL pending
seja exibido no admin da Shopify. No entanto, caso o problema persista após esse período, é provável que as configurações do provedor de domínio estejam incorretas.
Solução
Se o erro "TLS ou SSL indisponível" persistir após 48 horas, siga o procedimento:
- Verifique se o registro A é
23.227.38.65
, se o registro AAAA é2620:0127:f00f:5::
e se o registro CNAME éshops.myshopify.com
. - Se você usa registros de CAA, verifique se adicionou todas as autoridades de certificação necessárias.
- Se o DNSSEC estiver ativado no domínio, desative-o.
- Se você usa o Android 7.0 e versões anteriores, precisa atualizar o dispositivo.
- Se você usa uma versão de navegador anterior a 2010, atualize para a mais recente.
Caso precise de mais ajuda, entre em contato com o Atendimento ao cliente da Shopify.