不受支持的应用

您在商店中使用的某些应用可能因 Shopify API 更改而变得不受支持和停止工作。如果您商店中的应用使用不受支持的 API,您的 Shopify 后台中将显示通知。若要管理不受支持的应用,您可以联系应用开发者或在 Shopify 应用商店中查找新替代应用。详细了解如何管理不受支持的应用

如果您已安装的应用变得与您的商店不兼容,那么您将在 Shopify 后台中收到应用通知,说明哪些商店设置与应用不兼容。

应用如何变得不受支持

如果应用开发者未根据 Shopify API 的更改更新应用,则应用将变得不受支持。API(应用程序编程接口)是一个可供应用与 Shopify 进行通信的系统。您在商店中安装的应用使用 Shopify API 来获取和更新商店中的数据,并帮助您运营业务。

新的 Shopify API 版本每三个月发布一次。这些版本可能引入新功能或者更改和删除现有功能。每个版本的 Shopify API 都将持续工作一年,应用开发者必须在此期间内更新其应用才能使用更新的版本。

如果某个版本的 Shopify API 引入了会导致应用中断的更改,我们会通知应用开发者,并且他们有 9 个月的时间来更新应用。9 个月后,如果开发者未进行必要的更改,则该应用将变得不受支持,并且可能会停止工作。

管理不受支持的应用

不受支持的应用的更新由其开发者负责。可通过多种方式与应用开发者联系,具体取决于您使用的应用类型。

Shopify 会提早通知公共应用自定义应用开发者有关重大更改的信息,以便他们有时间更新应用,避免应用变得不受支持。

如果您使用的应用变得不受支持,您可以联系开发者并请求他们更新应用。您还可以在 Shopify 应用商店中查找其他应用,以防您无法联系到开发者,或者需要替换正在使用的应用。

由于这些应用由第三方开发者维护,因此 Shopify 无法对这些应用执行任何更改或更新。

不受支持的自定义应用

自定义应用是由开发者或开发公司专门为您的 Shopify 商店开发的应用。Shopify 会向应用开发者的联系电子邮件发送有关即将发布的 API 更改可能导致您的应用中断的信息。为了确保开发者可收到这些警告,您可以在自定义应用的应用设置页面查看和更新与自定义应用关联的账户。

不受支持的专有应用

专有应用是由开发者或开发公司专门为您的 Shopify 商店开发的应用。Shopify 会向应用开发者的联系电子邮件发送有关即将发布的 API 更改可能导致您的应用中断的信息。为了确保开发者可收到这些警告,您可以在 Shopify 后台的专有应用页面上查看和更新开发者的联系电子邮件

当您使用的专有应用变得不受支持时,您应联系该应用的开发者,请求他们更新该应用。您还应即时将收到的任何警告转发给应用开发者。

如果您没有开发者的联系邮箱,或者您不知道谁是您商店中安装的专有应用的开发者,请联系 Shopify 支持。如果您无法联系应用的原始开发者,则可聘请 Shopify 专家来帮助进行所需的更改。详细了解如何聘请 Shopify 专家

如果专有应用变得不受支持,并且您未使用该应用或不打算更新该应用,则可以删除该应用以忽略 Shopify 后台中的警告。

不受支持的销售渠道

Shopify 会提早通知任何第三方销售渠道开发者有关重大更改的信息,以便他们有时间更新渠道,避免渠道变得不受支持。

如果您使用的销售渠道不受支持,请联系开发者并请求他们对其进行更新。如果您无法联系到开发者,则应卸载销售渠道。

由于这些销售渠道由第三方开发者维护,因此 Shopify 无法对这些应用执行任何更改或更新。

安装不受支持的应用

如果您尝试安装不受支持的应用,可能会看到警告,说明应用可能无法正常工作,或者您无法安装该应用。您可以联系开发者并请求他们更新应用,也可以在 Shopify 应用商店中查找其他应用。

准备好开始使用 Shopify 进行销售了吗?

免费试用