Aplicaciones no compatibles

Es posible que algunas de las aplicaciones que uses en tu tienda dejen de ser compatibles y dejen de funcionar debido a cambios en las APIs de Shopify. Si una aplicación de tu tienda usa una API no compatible, se muestra una notificación en tu panel de control de Shopify. Puedes gestionar las aplicaciones no compatiblescontactando a los desarrolladores de la aplicación o remplazarla por otra de la Tienda de aplicaciones de Shopify.

Si una aplicación que ya instalaste deja de ser compatible con tu tienda, recibirás una notificación de la aplicación en el panel de control de Shopify explicando qué configuración de la tienda es incompatible con la aplicación.

Por qué las aplicaciones dejan de ser compatibles

Una aplicación deja de ser compatible si los desarrolladores de la aplicación no la mantienen actualizada según los cambios en las API de Shopify. Una API (interfaz de programación de aplicaciones) es un sistema que permite a las aplicaciones comunicarse con Shopify. Las aplicaciones que instalas en tu tienda utilizan las API de Shopify para recibir y actualizar datos de tu tienda y ayudarte a administrar tu negocio.

Cada tres meses se publican nuevas versiones de las API de Shopify. Estas versiones pueden introducir nuevas funciones o cambiar o eliminar funciones existentes. Cada versión de una API de Shopify sigue funcionando por un año antes de que los desarrolladores de aplicaciones deban actualizar sus aplicaciones para usar una versión más reciente.

Si una determinada versión de una API de Shopify introduce un cambio que interrumpe el funcionamiento de una aplicación, notificamos al desarrollador de dicha aplicación, y tienen 9 meses para actualizarla. Después de 9 meses, si el desarrollador no realiza los cambios requeridos, entonces la aplicación deja de ser compatible y podría dejar de funcionar como se espera.

Gestionar aplicaciones no compatibles

El desarrollador de una aplicación no compatible es responsable de actualizar su aplicación. Existen diferentes formas de comunicarte con el desarrollador de la aplicación; depende del tipo de aplicación que estés usando.

Shopify notifica a los desarrolladores de aplicaciones públicas y aplicaciones personalizadas sobre cambios importantes con suficiente antelación, de modo que tengan tiempo de actualizar sus aplicaciones antes de que dejen de ser compatibles.

Si una aplicación que estás usando deja de ser compatible, puedes ponerte en contacto con el desarrollador y solicitar que la actualice. También puedes buscar otras aplicaciones en la tienda de aplicaciones de Shopify en caso de que no puedas contactar al desarrollador, o necesitas remplazar la aplicación que estás usando.

Debido a que estas aplicaciones reciben mantenimiento de desarrolladores externos, Shopify no puede hacer ningún cambio ni actualizar estas aplicaciones.

Aplicaciones privadas no compatibles

Una aplicación privada está diseñada exclusivamente para tu tienda Shopify por un desarrollador o una empresa de desarrollo. Shopify envía información sobre los próximos cambios en las API que podrían interrumpir el funcionamiento de tu aplicación al correo electrónico de contacto del desarrollador de la aplicación. Para asegurarte de que el desarrollador recibe estas advertencias, puedes ver y actualizar el correo electrónico de contacto del desarrollador en la página de Aplicaciones privadas en el panel de control de Shopify.

Cuando una aplicación privada que estás usando deja de ser compatible, debes ponerte en contacto con el desarrollador de la aplicación para solicitar que la actualice. También deberías reenviar cualquier advertencia que recibas al desarrollador de la aplicación tan pronto como la recibas. Si no tienes un correo electrónico de contacto de tu desarrollador, o si no sabes quién creó una aplicación privada instalada en tu tienda, comunícate con el equipo de servicio técnico de Shopify

Si no puedes ponerte en contacto con el desarrollador original de la aplicación, puedes contratar a un Shopify Expert para que te ayude a hacer los cambios necesarios.

Si una aplicación privada deja de ser compatible, y no la estás utilizando o no tienes planes de actualizarla, puedes eliminar la aplicación para descartar la advertencia en tu panel de control de Shopify.

Canales de venta no compatibles

Shopify notifica a los desarrolladores de canales de ventas externos sobre cambios importantes con suficiente antelación para que tengan tiempo de actualizarlos antes de que dejen de ser compatibles.

Si un canal de ventas que estás usando deja de ser compatible, comunícate con el desarrollador y pídele que lo actualice. Si no puedes contactar al desarrollador, debes desinstalar el canal de ventas.

Debido a que estos canales de ventas reciben mantenimiento de desarrolladores externos, Shopify no puede hacer ningún cambio ni actualizar estos canales de ventas.

Instalar aplicaciones no compatibles

Si intentas instalar una aplicación no compatible, es posible que veas una advertencia de que la aplicación podría no funcionar correctamente, o que no podrás instalarla. Puedes ponerte en contacto con el desarrollador para pedirle que actualice la aplicación, o puedes buscar otras aplicaciones en la tienda de aplicaciones de Shopify.

¿Estas listo(a) para comenzar a vender con Shopify?

Pruébala gratis