Niet-ondersteunde apps

Sommige apps die u in uw winkel gebruikt, worden mogelijk niet ondersteund en werken niet naar behoren door wijzigingen in de API's van Shopify. Als een app die u hebt geïnstalleerd, niet-ondersteunde API's gebruikt, ziet u een waarschuwing in uw Shopify-beheerder. U kunt niet-ondersteunde apps beheren door contact op te nemen met de ontwikkelaars van de app of door een app vervangende app te zoeken.

Hoe apps verouderen

Een app verouderd als de ontwikkelaars van de app dit niet actueel houden met wijzigingen in de API's van Shopify. Een API (Application Programming Interface) is een systeem dat apps in staat stelt om te communiceren met Shopify. De apps die u in uw winkel installeert gebruiken Shopify API's om gegevens over uw winkel op te halen en bij te werken.

Er worden elke drie maanden nieuwe versies van Shopify API's vrijgegeven. Deze versies kunnen nieuwe features introduceren of bestaande features wijzigen en verwijderen. Elke versie van een Shopify API werkt nog een jaar voordat app-ontwikkelaars hun apps moeten bijwerken om een nieuwere versie te gebruiken.

Als een bepaalde versie van een Shopify API een wijziging introduceert die een app overtreedt, melden we de ontwikkelaar van die app en hebben ze negen maanden om deze bij te werken. Als de ontwikkelaar na negen maanden geen wijzigingen aanbrengt, wordt de app niet ondersteund en functioneert deze niet meer naar behoren.

Niet-ondersteunde apps beheren

De ontwikkelaar van een niet-ondersteunde app is verantwoordelijk voor het bijwerken van de app. Er zijn verschillende manieren om contact op te nemen met de app-ontwikkelaar, afhankelijk van het type app dat u gebruikt.

Niet-ondersteunde openbare apps

Elke app die u installeert vanuit de Shopify App Store is een openbare app. Shopify meldt de ontwikkelaars van openbare apps over het vroegtijdig wijzigen van wijzigingen, zodat ze tijd hebben om hun apps bij te werken voordat ze niet worden ondersteund.

Als een openbare app die u gebruikt, niet wordt ondersteund, kunt u contact opnemen met de ontwikkelaar en vragen om de app bij te werken. U kunt ook naar andere apps in de Shopify App Store zoeken in het geval dat u de ontwikkelaar niet kunt bereiken of dat u de app moet vervangen die u gebruikt.

Omdat openbare apps worden onderhouden door externe ontwikkelaars, kan Shopify geen wijzigingen aanbrengen of deze apps niet bijwerken voor u.

Niet-ondersteunde privé-apps

Een privé-app is exclusief gebouwd voor uw Shopify-winkel door een ontwikkelaar of ontwikkelingsbedrijf. Shopify verzendt informatie over aankomende API-wijzigingen die uw app kunnen beschadigen naar de contact e-mail van de app-ontwikkelaar. Om er zeker van te zijn dat de ontwikkelaar deze waarschuwingen krijgt, kunt u de contact e-mail van de ontwikkelaar bekijken en bijwerken op de pagina privé-apps in de Shopify-beheerder.

Wanneer een privé-app die u gebruikt, niet wordt ondersteund, moet u contact opnemen met de ontwikkelaar van de app om bij te werken. U moet ook alle waarschuwingen die u aan de app-ontwikkelaar krijgt, doorstuurt zodra u ze hebt ontvangen. Neem contact op met Shopify-ondersteuningals u geen contact mail hebt voor uw ontwikkelaar of als u niet weet wie een privé-app heeft ontwikkeld die in uw winkel is geïnstalleerd.

Als u geen contact kunt opnemen met de oorspronkelijke ontwikkelaar van de app, kunt u een Shopify-expert inhuren om u te helpen de gewenste wijzigingen aan te brengen.

Als een privé-app niet wordt ondersteund en u deze niet gebruikt of niet van plan bent om deze bij te werken, kun je de app verwijderen om de waarschuwing te annuleren in je Shopify-beheerder.

Klaar om te beginnen met verkopen met Shopify?

Probeer het gratis