Apper som ikke støttes

Noen av appene du bruker i butikken din kan bli ustøttet og slutte å fungere på grunn av endringer i Shopify API-ene. Hvis en app du har installert bruker ikke-støttede API-er, vil du se en advarsel i Shopify-administrator. Du kan administrere ikke-støttede apper ved å kontakte appens utviklere eller finne en app for å erstatte den.

Hvordan apper blir ustøttet

En app blir ustøttet hvis appens utviklere ikke holder den oppdatert i takt med endringer i Shopify API-er. Et API (Application Programming Interface) er et system som gjør det mulig for apper å kommunisere med Shopify. Appene du installerer i butikken din bruker Shopify API-er for å hente og oppdatere data i butikken din og hjelpe deg å drive bedriften din.

Nye versjoner av Shopify API-er blir utgitt hver tredje måned. Disse versjonene kan introdusere nye funksjoner eller endre og fjerne eksisterende funksjoner. Hver versjon av en Shopify-API fortsetter å fungere i et år før app-utviklere må oppdatere appene sine for å bruke en nyere versjon.

Hvis en bestemt versjon av en Shopify API introduserer en endring som kan få en app til å slutte å fungere, vil vi varsle utvikleren av appen, og de har 9 måneder til å oppdatere den. Etter 9 måneder, hvis utvikleren ikke gjør de nødvendige endringene, blir appen ustøttet, og kan slutte å fungere som forventet.

Administrere ikke-støttede apper

Utvikleren av en app som ikke støttes er ansvarlig for å oppdatere appen sin. Det er ulike måter å nå ut til app-utvikleren som avhenger av typen app du bruker.

Offentlige apper som ikke støttes

Alle appene du installerer fra Shopify App Store er en offentlig app. Shopify varsler utviklerne av offentlige apper om ødeleggende endringer tidlig, slik at de har tid til å oppdatere appene før de blir ustøttet.

Hvis en offentlig app du bruker ikke støttes, kan du kontakte utvikleren og be om at de oppdaterer appen. Du kan også se etter andre apper i Shopify App Store i tilfelle du ikke når utvikleren, eller du må erstatte appen du bruker.

Ettersom offentlige apper opprettholdes av tredjepartsutviklere, kan ikke Shopify gjøre noen endringer eller oppdatere disse appene for deg.

Ikke-støttede private apper

En privat app er bygget eksklusivt for Shopify-butikken din av en utvikler eller et utviklingsselskap. Shopify sender informasjon om kommende API-endringer som kan ødelegge appen din til apputviklerens kontakt-e-post. For å sikre at utvikleren får disse advarslene, kan du se og oppdatere utviklerens kontakt-e-postPrivate apper-siden i Shopify-administrator.

Når en privat app du bruker blir ikke-støttet, bør du kontakte utvikleren av appen for å be dem om å oppdatere den. Du bør også videresende eventuelle advarsler du får til app-utvikleren så snart du får dem.
Hvis du ikke har en kontakt-e-post for utvikleren, eller du ikke vet hvem som har utviklet en privat app installert i butikken din, kan du kontakte Shopify-brukerstøtte

Hvis du ikke kan kontakte den opprinnelige utvikleren av appen, kan du leie en Shopify-ekspert for å hjelpe deg med å gjøre de nødvendige endringene.

Hvis en privat app ikke støttes, og du ikke bruker den eller ikke planlegger å oppdatere den, kan du slette appen for å fjerne advarselen i Shopify-administrator.

Er du klar til å begynne å selge med Shopify?

Prøv det gratis